hdu1160-最长上升子序列

该问题要求构造一个子序列,使得鼠标重量递增但速度递减,尽可能包含更多的数据点。输入包含多组鼠标数据,每组由重量和速度组成,输出为满足条件的最大子序列长度及序列本身。可以通过排序和动态规划求解。
摘要由CSDN通过智能技术生成

FatMouse’s Speed

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13991 Accepted Submission(s): 6179
Special Judge

Problem Description
FatMouse believes that the fatter(胖的) a mouse is, the faster it runs. To disprove(反驳) this, you want to take the data on a collection of mice and put as large a subset(子集) of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.

Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.

Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],…, m[n] then it must be the case that

W[m[1]] < W[m[2]] < … < W[m[n]]

and

S[m[1]] > S[m[2]] > … > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities(不平等) are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.

Sample Input

6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900

Sample Output

4
4
5
9
7

Source
Zhejiang University Training Contest 2001

题解:先将输入的进行排序,然后对i之前的序列进行遍历符合题目要去的进行判断dp[i]=max(dp[i],dp[j]+1)

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <stack>
using namespace std;
struct mice
{
    int w,s;
    int index;
}mou[1010];
bool cmp(const mice &ele1,const mice &ele2){
    if(ele1.w<ele2.w)return true;
    else if(ele1.w==ele2.w){
        if(ele1.s>=ele2.s)return true;
        else return false;
    }
    else return false;

}
int pre[1010];
int dp[1010];
int main(){
    int a,b,i,j,cnt,max;
    cnt=0;
    //freopen("in.txt","r",stdin);
    //memset(dp,1,sizeof(dp));
    memset(pre,-1,sizeof(pre));
    while(scanf("%d%d",&a,&b)!=EOF){
        mou[cnt].w=a;
        mou[cnt].s=b;
        mou[cnt].index=cnt+1;
        cnt++;
    }
    for ( i = 0; i < cnt; ++i)
    {
        dp[i]=1;
    }
    sort(mou,mou+cnt,cmp);
    max=0;
    for ( i = 0; i < cnt; ++i)
    {
        for ( j = 0; j < i; ++j)
        {
            if(mou[j].w<mou[i].w&&mou[j].s>mou[i].s&&dp[j]+1>dp[i]){
                dp[i]=dp[j]+1;
                pre[i]=j;
            }
        }
        if(dp[i]>max){
            max=dp[i];
            a=i;
        }


    }
    stack<int> s;
    s.push(a);
    while(a!=-1){
        a=pre[a];
        if(a==-1)break;
        s.push(a);
    }
    printf("%d\n", max);
    while(!s.empty()){
        cout<<mou[s.top()].index<<endl;
        s.pop();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值