POJ 3468 A Simple Problem with Integers

A Simple Problem with Integers
Time Limit:5000MS     Memory Limit:131072KB     64bit IO Format:%I64d & %I64u

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C abc" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q ab" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.


#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
using namespace std;
#define N 100002
struct node
{
    int l,r;
    long long lz,w;
} q[4*N];
void pushup(int rt)
{
    q[rt].w=q[rt*2].w+q[rt*2+1].w;
}
void pushdown(int rt,int m)
{
    if(q[rt].lz)
    {
        q[rt*2].lz+=q[rt].lz;
        q[rt*2+1].lz+=q[rt].lz;
        q[rt*2].w+=(m-m/2)*q[rt].lz;
        q[rt*2+1].w+=(m/2)*q[rt].lz;
        q[rt].lz=0;
    }
}
void build(int l,int r,int rt)
{
    q[rt].l=l;
    q[rt].r=r;
    q[rt].lz=0;
    if(l==r)
    {
        scanf("%I64d",&q[rt].w);
        return ;
    }
    build(l,(r+l)/2,rt*2);
    build((r+l)/2+1,r,rt*2+1);
    pushup(rt);
}
void update(int key,int ll,int rr,int l,int r,int rt)
{
    if(ll>r || rr<l)
    {
        return ;
    }
    if(ll<=l&&rr>=r)
    {
        q[rt].w+=(long long)key*(r-l+1);
        q[rt].lz+=key;
        return ;
    }
    pushdown(rt,r-l+1);
    int m=(r+l)/2;
    if(ll<=m)
        update(key,ll,rr,l,m,rt*2);
    if(rr>m)
    {
        update(key,ll,rr,m+1,r,rt*2+1);
    }
    pushup(rt);
}
/*
long long query(int ll,int rr,int l,int r,int rt)
{
    if(ll<=l&&rr>=r)
    {
        return q[rt].w;
    }
    pushdown(rt,r-l+1);
    int m=(r+l)/2;
    long long L=0;
    if(ll<=m) L+=query(ll,rr,l,m,rt*2);
    if(rr>m) L+=query(ll,rr,m+1,r,rt*2+1);
    return L;
}
*/


long long query(int ll,int rr,int l,int r,int rt)
{
    if(rr<l || ll>r)
    {
        return 0;
    }
    if(ll<=l && rr>=r)
    {
        return q[rt].w;
    }

    pushdown(rt,r-l+1);
    int kk = (r+l)>>1;
    long long  ret = 0;
    return (query(ll,rr,l,kk,rt<<1)+query(ll,rr,kk+1,r,rt<<1|1));

}
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        build(1,n,1);
        while(m--)
        {
            char op[10];
            int a , b , c;
            scanf("%s",op);
            if (op[0] == 'Q')
            {
                scanf("%d%d",&a,&b);
                long long tt=query(a,b,1,n,1);
                printf("%I64d\n",tt);
            }
            else
            {
                scanf("%d%d%d",&a,&b,&c);
                update(c,a,b,1,n,1);
            }
        }
    }
    return 0;

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值