SDUTOJ 2482 二叉排序树

二叉排序树

Time Limit: 1000MS Memory limit: 65536K

题目描述

二叉排序树的定义是:或者是一棵空树,或者是具有下列性质的二叉树: 若它的左子树不空,则左子树上所有结点的值均小于它的根结点的值; 若它的右子树不空,则右子树上所有结点的值均大于它的根结点的值; 它的左、右子树也分别为二叉排序树。 今天我们要判断两序列是否为同一二叉排序树

输入

开始一个数n,(1<=n<=20) 表示有n个需要判断,n= 0 的时候输入结束。
接下去一行是一个序列,序列长度小于10,包含(0~9)的数字,没有重复数字,根据这个序列可以构造出一颗二叉排序树。
接下去的n行有n个序列,每个序列格式跟第一个序列一样,请判断这两个序列是否能组成同一颗二叉排序树。(数据保证不会有空树)

输出

示例输入

2
123456789
987654321
432156789
0

示例输出

NO
NO

提示

 

来源

 

示例程序

 
明白二叉树就知道这是什么东西了。。。

中序遍历就不可以.......

示例代码:

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<string>


using namespace std;


struct node
{
    char data;
    struct node *left,*right;
};


int n;


struct node *creat(struct node *&root,char m)
{
    if(root == NULL)
    {
        root = (struct node*)malloc(sizeof(struct node));
        root->left = NULL;
        root->right = NULL;
        root->data = m;
    }
    else
    {
        if(m < root->data)
        {
            creat(root->left,m);
        }
        else
        {
            creat(root->right,m);
        }
    }
}
int s;
char a[10001],b[10000];
void xianxu(struct node *root)
{
    if(root!=NULL)
    {
        a[s++] = root->data;
        xianxu(root->left);
        xianxu(root->right);
    }
}


int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        char m;
        char str[10001],str1[11100];
        struct node *root = NULL;
        scanf("%s",&str);
        s = 0;
        for(int i=0;str[i]!='\0';i++)
        {
            creat(root,str[i]);
        }
        xianxu(root);
        a[s] = '\0';
        strcpy(b,a);
        //printf("b = %s\n",b);
        for(int i=0;i<n;i++)
        {
            s = 0;
            scanf("%s",str1);
            struct node *pp = NULL;
            for(int j=0;str1[j]!='\0';j++)
            {
                creat(pp,str1[j]);
            }
            xianxu(pp);
            a[s] = '\0';
            //printf("a = %s\n",a);
            if(strcmp(a,b) == 0)
            {
                printf("YES\n");
            }
            else
            {
                printf("NO\n");
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值