SDUTOJ 3035 你猜我猜不猜你猜不猜

你猜我猜不猜你猜不猜

Time Limit: 2000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

In the past 39th annual ACM international collegiate programming contest in Beijing station in Asia that Triple_S sent by our school team won the SDUT in Reginal bronze 11. At the same time,the team’s name is cray which is to let the host after reading the wrong three times, still missed a word to read. But  zhuhu gave a high evaluation to the team.
 
As the creator of this team, I want to say is,  in fact I was reminded of a game which is named ”ni cai wo cai bu cai ni cai bu cai wo cai bu cai”, may be the teacher didn\'t remember it. The name is just due to a conversation with a girl, so the origin is simple.
 
A:Why are you so diao?
 
B:Ni cai.
 
A:Ni cai wo cai bu cai.
 
B:Ni cai wo cai bu cai ni cai bu cai.
 
A:Ni cai wo cai bu cai ni cai bu cai wo cai bu cai.
 
Then do you know the content of their first conversation X?OK,in order to avoid the mle , RE professionals will popularize related knowledge for you . Please seize this chance!
 
The operation is very simple, only need to output the first letter of each word .For example , You can substitute N for Ni . Next, I\'ll demonstrate specific operation steps

输入

  For everytestcase , each line of input  a  Character   , said A or B .

Then enter an Integer X (0<=X<=10^5), said the figure’s the first  X words.

输出

  Output the words.

示例输入

A 2
A 3
B 3

示例输出

Ncwcbc
Ncwcbcncbcwcbc
Ncwcbcncbcwcbcncbc

提示

 输入请用 cin

来源

  Flyfire

 

示例程序





#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<string>
#include<stdlib.h>


using namespace std;


int main()
{
    char c[100];
    while(cin >> c)
    {
        string b,a;
        int x;
        if(c[0] == 'A')
        {
            scanf("%d",&x);
            if(x == 1)
            {
                cout << "Waysd" << endl;
            }
            else
            {
                if(x == 2)
                {
                    cout << "Ncwcbc" << endl;
                }
                else
                {
                    cout << "Ncwcbc";
                    for(int i=3; i<=x; i++)
                    {
                        cout << "ncbcwcbc";
                    }
                    cout << endl;
                }


            }
        }
        else if(c[0] == 'B')
        {
            scanf("%d",&x);
            if(x == 1)
            {
                cout << "Nc" << endl;
            }
            else
            {
                cout << "Nc";
                for(int j=2; j<=x; j++)
                {
                   cout << "wcbcncbc";
                }
                cout << endl;
            }


        }
    }
    return 0;
}
 






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值