UVA Andy's First Dictionary(模拟+字符串排序)

Andy's First Dictionary
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

Download as PDF

Problem B: Andy's First Dictionary

Time limit: 3 seconds


Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his bookshelf he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this is where a computer program is helpful.

You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case. Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE. For example, words like "Apple", "apple" or "APPLE" must be considered the same.

Input

The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF.

Output

Your output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words in the text does not exceed 5000.

Sample Input

Adventures in Disneyland

Two blondes were going to Disneyland when they came to a fork in the
road. The sign read: "Disneyland Left."

So they went home.

Sample Output

a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
so
the
they
to
two
went
were
when


Joke and image taken from the Web

题意简单的说就是文章转换成单词然后排序输出


#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

char a[6000][600];
char b[2000000][100];

int cmp(const void *aa,const void *bb)
{
    return strcmp((char*)aa,(char*)bb);
}

int main()
{
    int n = 0;
    while(gets(a[n])!=NULL)
    {
        n++;
    }
    int t = 0,k = 0;
    int flag = 0;
    for(int i=0; i<n; i++)
    {
        for(int j=0; a[i][j]!='\0'; j++)
        {
            if((a[i][j]>='a' && a[i][j]<='z') || (a[i][j]>='A' && a[i][j] <='Z'))
            {
                if(a[i][j]>='A' && a[i][j]<='Z')
                {
                    a[i][j] = a[i][j] + 32;
                }
                b[t][k] = a[i][j];
                k++;
            }
            else
            {
                    b[t][k] = '\0';
                    t++;
                    k = 0;

            }
        }
            b[t][k] = '\0';
            k = 0;
            t++;

    }
    /*for(int i=0; i<t; i++)
    {
        printf("b[%d] = %s\n",i,b[i]);
    }*/
    qsort(b,t,sizeof(b[0]),cmp);
    int h = 0;
    for(int i=0; i<t; i++)
    {
        if(b[i][0] >='a' && b[i][0]<='z')
        {
            h = i;
            break;
        }
    }
    printf("%s\n",b[h]);
    for(int i=h+1; i<t; i++)
    {
        if(strcmp(b[i],b[i-1]) !=0)
        {
            printf("%s\n",b[i]);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值