UVA Pseudo-Random Numbers

 Pseudo-Random Numbers 

Computers normally cannot generate really random numbers, but frequently are used to generate sequences of pseudo-random numbers. These are generated by some algorithm, but appear for all practical purposes to be really random. Random numbers are used in many applications, including simulation.

A common pseudo-random number generation technique is called the linear congruential method. If the last pseudo-random number generated was L, then the next number is generated by evaluating ( tex2html_wrap_inline32 , where Z is a constant multiplier, I is a constant increment, and M is a constant modulus. For example, suppose Z is 7, I is 5, and M is 12. If the first random number (usually called theseed) is 4, then we can determine the next few pseudo-random numbers are follows:

tabular21

As you can see, the sequence of pseudo-random numbers generated by this technique repeats after six numbers. It should be clear that the longest sequence that can be generated using this technique is limited by the modulus, M.

In this problem you will be given sets of values for ZIM, and the seed, L. Each of these will have no more than four digits. For each such set of values you are to determine the length of the cycle of pseudo-random numbers that will be generated. But be careful: the cycle might not begin with the seed!

Input

Each input line will contain four integer values, in order, for ZIM, and L. The last line will contain four zeroes, and marks the end of the input data. L will be less than M.

Output

For each input line, display the case number (they are sequentially numbered, starting with 1) and the length of the sequence of pseudo-random numbers before the sequence is repeated.

Sample Input

7 5 12 4
5173 3849 3279 1511
9111 5309 6000 1234
1079 2136 9999 1237
0 0 0 0

Sample Output

Case 1: 6
Case 2: 546
Case 3: 500
Case 4: 220



    题意:每次输入四个数据Z,I,M,L,根据伪随机数的原理,求种子轮回周期的大小。式子已经在题目中给出:L = (Z*L+I) mod M,不过题目有一个陷阱就是题目给出的L并不一定就是初始的种子,需要自己判断。(可以设立一个数组把所有出现过得种子全部储存下来,如果再次出现就是初始种子)


代码:

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

int a[100000000];

int main()
{
    long long int Z,I,M,L;
    int k = 0;
    while(scanf("%lld%lld%lld%lld",&Z,&I,&M,&L)!=EOF)
    {
        if(Z == 0 && I == 0 && M == 0 && L == 0)
        {
            break;
        }
         for(int i=0;i<M;i++)
         {
             a[i] = 0;
         }
        k++;
        int pl = L%M;
        a[pl] = 1;
        int count = 0;
        long long int sum = 0;
        while(1)
        {
            count++;
            Z = Z % M;
            sum = (Z * L);
            sum = sum + (I%M);
            L = sum % M;
            if(L == pl)
            {
                break;
            }
            if(a[L] == 1)
            {
                count--;
                break;
            }
            a[L] = 1;
        }
        printf("Case %d: %d\n",k,count);
    }
    return 0;
}


    

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值