UVA Simple calculations (数学推导)

The Problem

There is a sequence of n+2 elements a0, a1,…, an+1 (n <= 3000; -1000 <=  ai 1000). It is known that ai = (ai–1 + ai+1)/2 – ci   for each i=1, 2, ..., n. You are given a0, an+1, c1, ... , cn. Write a program which calculates a1.

The Input

The first line is the number of test cases, followed by a blank line.

For each test case, the first line of an input file contains an integer n. The next two lines consist of numbers a0 and an+1 each having two digits after decimal point, and the next n lines contain numbers ci (also with two digits after decimal point), one number per line.

Each test case will be separated by a single line.

The Output

For each test case, the output file should contain a1 in the same format as a0 and an+1.

Print a blank line between the outputs for two consecutive test cases.

Sample Input

1150.5025.5010.15

Sample Output

27.85
 
 
 
题意:给出a[0],和a[n+1],以及c[1]~c[n]的值,有公式
a[i] = (a[i-1] + a[i+1])/2 - c[i];
然后求a[1]的值。

根据公式推导:
a[1] = n*a[0] + a[n+1] -2*n*c[1] - 2*(n-1)*c[2] --->>> - 2*1*c[n];

a[1]就可以了.
代码:
#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>

using namespace std;

double c[100010];

int main()
{
    int T;
    double a0,an;
    scanf("%d",&T);
    while(T--)
    {
        double n;
        scanf("%lf",&n);
        scanf("%lf",&a0);
        scanf("%lf",&an);
        for(int i=1;i<=n;i++)
        {
            scanf("%lf",&c[i]);
        }
        double sum = 0;
        sum = n*a0 + an;
        for(int i=1;i<=n;i++)
        {
            sum = sum - 2.0 *(n-i+1) * c[i];
        }
        sum = sum / (n+1);
        printf("%.2lf\n",sum);
        if(T!=0)
            cout<<endl;
    }
    return 0;
}

 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值