UVA The die is cast (BFS)

  The die is cast 

InterGames is a high-tech startup company that specializes in developing technology that allows users to play games over the Internet. A market analysis has alerted them to the fact that games of chance are pretty popular among their potential customers. Be it Monopoly, ludo or backgammon, most of these games involve throwing dice at some stage of the game.

Of course, it would be unreasonable if players were allowed to throw their dice and then enter the result into the computer, since cheating would be way to easy. So, instead, InterGames has decided to supply their users with a camera that takes a picture of the thrown dice, analyzes the picture and then transmits the outcome of the throw automatically.

For this they desperately need a program that, given an image containing several dice, determines the numbers of dots on the dice.

We make the following assumptions about the input images. The images contain only three dif- ferent pixel values: for the background, the dice and the dots on the dice. We consider two pixels connected if they share an edge - meeting at a corner is not enough. In the figure, pixels A and B are connected, but B and C are not.

A set S of pixels is connected if for every pair (a,b) of pixels in S, there is a sequence $a_1, a_2, \dots, a_k$ in S such that a = a1 and b = ak , and ai and ai+1 are connected for $1 \le i < k$.

We consider all maximally connected sets consisting solely of non-background pixels to be dice. `Maximally connected' means that you cannot add any other non-background pixels to the set without making it dis-connected. Likewise we consider every maximal connected set of dot pixels to form a dot.

Input 

The input consists of pictures of several dice throws. Each picture description starts with a line containing two numbers w and h, the width and height of the picture, respectively. These values satisfy $5 \leŸw,h \le 50$.

The following h lines contain w characters each. The characters can be: ``.'' for a background pixel, ``*'' for a pixel of a die, and ``X'' for a pixel of a die's dot.

Dice may have different sizes and not be entirely square due to optical distortion. The picture will contain at least one die, and the numbers of dots per die is between 1 and 6, inclusive.

The input is terminated by a picture starting with w = h = 0, which should not be processed.

Output 

For each throw of dice, first output its number. Then output the number of dots on the dice in the picture, sorted in increasing order.

Print a blank line after each test case.

Sample Input 

30 15
..............................
..............................
...............*..............
...*****......****............
...*X***.....**X***...........
...*****....***X**............
...***X*.....****.............
...*****.......*..............
..............................
........***........******.....
.......**X****.....*X**X*.....
......*******......******.....
.....****X**.......*X**X*.....
........***........******.....
..............................
0 0

Sample Output 

Throw 1
1 2 2 4


       题意:在一个大地图中分布着许多只有*和X的小块,求这些小块中有多少X(其中一个X的上下左右方向如果存在X,那么这个X不进入计数)。最后把所有的小块中的X的值按升序输出。



代码:

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<string>
#include<queue>

using namespace std;

struct node
{
    int x;
    int y;
}p[30010];

int n,m;
int pjx[] = {0,1,0,-1};
int pjy[] = {1,0,-1,0};
//int jx[] = {0,1,-1,0,1,1,-1,-1};
//int jy[] = {1,0,0,-1,1,-1,1,-1};
char map[101][101];
int v[101][101];

int BFS2(int ee)
{
    int cc = 0;
    queue<node>q1;
    struct node t,f;
    memset(v,0,sizeof(v));
    for(int i=0;i<ee;i++)
    {
        if(v[p[i].x][p[i].y] == 0)
        {
            t.x = p[i].x;
            t.y = p[i].y;
            v[t.x][t.y] = 1;
            map[t.x][t.y] = '.';
            q1.push(t);
            while(!q1.empty())
            {
                t = q1.front();
                q1.pop();
                for(int j=0;j<4;j++)
                {
                    f.x = t.x + pjx[j];
                    f.y = t.y + pjy[j];
                    if(f.x>=0 && f.x<n && f.y>=0 && f.y<m && map[f.x][f.y] == 'X')
                    {
                        q1.push(f);
                        map[f.x][f.y] = '.';
                        v[f.x][f.y] = 1;
                        cc++;
                    }
                }
            }
        }
    }
    return cc;
}

int BFS(int ii,int jj)
{
    struct node r;
    int ee = 0;
    int count = 0;
    queue<node>q;
    memset(v,0,sizeof(v));
    node t,f;
    t.x = ii;
    t.y = jj;
    q.push(t);
    if(map[t.x][t.y] == 'X')
    {
        p[ee++] = t;
        count++;
    }
    v[t.x][t.y] = 1;
    while(!q.empty())
    {
        t = q.front();
        q.pop();
        for(int i=0;i<4;i++)
        {
            f.x = t.x + pjx[i];
            f.y = t.y + pjy[i];
            if(f.x>=0 && f.x<n && f.y>=0 && f.y<m && (map[f.x][f.y] == '*' || map[f.x][f.y] == 'X') && v[f.x][f.y] == 0)
            {
                if(map[f.x][f.y] == 'X')
                {
                    r.x = f.x;
                    r.y = f.y;
                    p[ee++] = r;
                    count++;
                }
                else
                {
                    map[f.x][f.y] = '.';
                }
                q.push(f);
                v[f.x][f.y] = 1;
            }
        }
    }
    int cc = BFS2(ee);
    return count - cc;
}

int main()
{
    int kk = 0;
    int a[30100];
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        if(n == 0 && m == 0)
        {
            break;
        }
        kk++;
        memset(a,0,sizeof(a));
        int e = 0;
        for(int i=0;i<n;i++)
        {
            scanf("%s",map[i]);
        }
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                if(map[i][j] == '*' || map[i][j] == 'X')
                {
                    int k = BFS(i,j);
                    a[e++] = k;
                }
            }
        }
        sort(a,a+e);
        printf("Throw %d\n",kk);
        for(int i=0;i<e-1;i++)
        {
            printf("%d ",a[i]);
        }
        printf("%d\n\n",a[e-1]);
    }
    return 0;
}





Miguel Revilla
2000-05-22

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值