HDU 5003 Osu!(水题)

Osu!
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Osu! is a famous music game that attracts a lot of people. In osu!, there is a performance scoring system, which evaluates your performance. Each song you have played will have a score. And the system will sort all you scores in descending order. After that, the i-th song scored a  i will add 0.95^(i-1)*a  i to your total score. 

Now you are given the task to write a calculator for this system.
 

Input

The first line contains an integer T, denoting the number of the test cases. 

For each test case, the first line contains an integer n, denoting the number of songs you have played. The second line contains n integers a 1, a  2, ..., a  n separated by a single space, denoting the score of each song. 

T<=20, n<=50, 1<=a  i<=500.
 

Output

For each test case, output one line for the answer. 

Your answers will be considered correct if its absolute error is smaller than 1e-5.
 

Sample Input

       
       
1 2 530 478
 

Sample Output

       
       
984.1000000000
 




#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

double a[1001];
int n;

int cmp(const void *a,const void *b)
{
     return *(double *)b > *(double *)a ? 1 : -1;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%lf",&a[i]);
        }
        qsort(a,n,sizeof(a[0]),cmp);
        double sum = a[0];
        double h = 0.95;
        for(int i=1;i<n;i++)
        {
            sum += h * a[i];
            h = h * 0.95;
        }
        printf("%.10lf\n",sum);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值