第四届山东省赛 Thrall’s Dream(BFS+vector)

2218: Thrall’s Dream

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 253   Solved: 72
[ Submit][ Status][ Web Board]

Description

We never paid any heed to the ancient prophecies, like fools we clung to the old hatreds, and fought as we had for generations. Until one day the sky rained fire, and a new enemy came upon us. We stand now upon the brink of destruction, for the Reign of Chaos has come at last.

Thrall, the warchief of the Orcish Horde, all along, he led his tribe live in the fringe of Lordaeron under the human control. In a downpour night, Thrall falls into sleep in a Orc hall at Arathi Highlands, at this moment he heard a voice:

“The sands of time have run out, son of Durotan. The cries of war echo upon the winds, the remnants of the past scar the land which is besieged once again by conflict. Heroes arise to challenge fate, and lead their brethren to battle. As mortal armies rush blindly towards their doom, The Burning Shadow comes to consume us all. You must rally the Horde, and lead your people to their destiny.

I will answer all of your questions in time, young warchief. For now, rally your warriors and prepare to leave this land, cross the sea to the distant land of Kalimdor. We will speak again. ”


Thrall believes the prophesy of Blood Raven Medivh. Three days later, He and Grom Hellscream's Warsong Clan meet in the Lordaeron coast to the distant lands of Kalimdor. But the Goblin Zeppelins they take encountered storms in the middle. Thrall and Grom falling to the islands, they want to find each other and then to Kalimdor.

For the sake of simplicity, we assume that Thrall and Grom may fall into any islands x and y, only by Thrall to find Grom or by Grom to find Thrall. Give you the map of this island, please judge that Thrall and Gtom can meet?

Input

There are multiple test case in the input file, first line is a case number T. Each test case will begin with two integers N (0 <= N < 2001) and M (0 <= M < 10001), where N is the number of islands and M is number of portal. Next M lines each line contains two integers a and b, indicated there is a portal in island a that people can go from a to b by this portal. The island numbered from 1 to N.

Output

For each test case, your output should be in one line with “Kalimdor is just ahead” (without quotes, hereinafter the same) if Thrall and Grom can meet or “The Burning Shadow consume us all” otherwise as indicated in the sample output. 

Sample Input

2
3 2
1 2
1 3

3 2
1 2
2 3

Sample Output

Case 1: The Burning Shadow consume us all
Case 2: Kalimdor is just ahead

HINT

Source

2013年山东省第四届ACM大学生程序设计竞赛



因为题目中的数据范围太大,可以选择不定长数组进行记录,这样省时间



#include<iostream>  
#include<algorithm>  
#include<stdio.h>  
#include<string.h>  
#include<stdlib.h>  
#include<queue>  
#include<vector>  
  
using namespace std;  
  
int n,m;  
bool v[2015],mm[2015][2015];  
vector<int>map[2015];  
  
void BFS(int x)  
{  
    queue<int>q;  
    while(!q.empty())  
    {  
        q.pop();  
    }  
    for(int j=0; j<map[x].size(); j++)  
    {  
        q.push(map[x][j]);  
        v[map[x][j]] = true;  
    }  
    v[x] = true;  
    while(!q.empty())  
    {  
        int t = q.front();  
        q.pop();  
        for(int j=0; j<map[t].size(); j++)  
        {  
            if(v[map[t][j]] == 0)  
            {  
                v[map[t][j]] = true;  
                q.push(map[t][j]);  
                mm[x][map[t][j]] = true;  
            }  
  
        }  
    }  
}  
  
int main()  
{  
    int T;  
    int kk = 0;  
    scanf("%d",&T);  
    while(T--)  
    {  
        int x,y;  
        scanf("%d%d",&n,&m);  
        for(int i=0; i<=n; i++)  
        {  
            for(int j=0; j<=n; j++)  
            {  
                mm[i][j] = false;  
            }  
            mm[i][i] = true;  
        }  
        for(int i=1; i<=n; i++)  
        {  
            map[i].clear();  
        }  
        for(int i=0; i<m; i++)  
        {  
            scanf("%d%d",&x,&y);  
            map[x].push_back(y);  
            mm[x][y] = true;  
        }  
        int flag = 0;  
        for(int i=1; i<=n; i++)  
        {  
            memset(v,0,sizeof(v));  
            BFS(i);  
        }  
        for(int i=1;i<=n;i++)  
        {  
            for(int j=1;j<=n;j++)  
            {  
                if(mm[i][j] == 0 && mm[j][i] == 0)  
                {  
                    flag = 1;  
                    printf("Case %d: The Burning Shadow consume us all\n",++kk);  
                    break;  
                }  
            }  
            if(flag == 1)  
            {  
                break;  
            }  
        }  
        if(flag == 0)  
        {  
            printf("Case %d: Kalimdor is just ahead\n",++kk);  
        }  
  
    }  
    return 0;  
}  















评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值