POJ 1129 Channel Allocation(DFS)

Channel Allocation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 13173 Accepted: 6737

Description

When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels. 

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of channels required.

Input

The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example, ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input. 

Following the number of repeaters is a list of adjacency relationships. Each line has the form: 

A:BCDH 

which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form 

A: 

The repeaters are listed in alphabetical order. 

Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross. 

Output

For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when only one channel is required.

Sample Input

2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0

Sample Output

1 channel needed.
3 channels needed.
4 channels needed. 
 
 
 
 
     题意:平面内最多26个点,给出一些点与点之间的矛盾关系,问最少使用多少颜

色才能给这些点染色,并保证矛盾点之间不同色。

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<vector>

using namespace std;

int n;
int v[30];
char str[31];
int minn;
vector<int>q[30];

int up(int x,int k)
{
    for(int i=0;i<q[x].size();i++)
    {
        if(v[q[x][i]] == k)
        {
            return -1;
        }
    }
    return 1;
}

void DFS(int m,int num)
{
    if(m == n)
    {
        minn = min(minn,num);
        return ;
    }
    for(int i=0;i<num;i++)
    {
        v[m] = i;
        if(up(m,i) == 1)
        {
            DFS(m+1,num);
        }
    }
    v[m] = num;
    DFS(m+1,num+1);
    v[m] = -1;
}

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        if(n == 0)
        {
            break;
        }
        minn = 999999;
        for(int i=0;i<=30;i++)
        {
            q[i].clear();
        }
        for(int i=0;i<n;i++)
        {
            scanf("%s",str);
            for(int j=2;str[j]!='\0';j++)
            {
                q[(str[0]-'A')].push_back(str[j]-'A');
            }
        }
        for(int i=0;i<30;i++)
        {
            v[i] = -1;
        }
        DFS(0,0);
        if(minn == 1)
        {
            printf("1 channel needed.\n");
        }
        else
        {
            printf("%d channels needed.\n",minn);
        }
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值