POJ 1159 Palindrome(DP + 滚动数组)

Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 56273 Accepted: 19455

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

Source






    题意:要求添加最少的字符能使得成为回文串,

    需要知道   最少需要补充的字母数 = 原序列str1的长度 —  str1和str2的最长公共子串长度

    因为N等于5000,所以int会MLE,不过使用short int 就不会。也可以使用滚动数组  因为dp[i][j]都是又他的左边,上边,左上得来的,所以滚动数组可以开到2.很省内存。




short int 过的
#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

const int N = 5001;

short int dp[N][N];
char str1[N];
char str2[N];
int n;

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        scanf("%s",str1+1);
        int k = n;
        for(int i=1;i<=n;i++)
        {
            str2[k] = str1[i];
            k--;
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(str1[i] == str2[j])
                {
                    dp[i][j] = dp[i-1][j-1] + 1;
                }
                else
                {
                    dp[i][j] = max(dp[i-1][j],dp[i][j-1]);
                }
            }
        }
        printf("%d\n",n-dp[n][n]);
    }
    return 0;
}




滚动数组

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

const int N = 5001;

short int dp[2][N];
char str1[N];
char str2[N];
int n;

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        scanf("%s",str1+1);
        int k = n;
        for(int i=1;i<=n;i++)
        {
            str2[k] = str1[i];
            k--;
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(str1[i] == str2[j])
                {
                    dp[i%2][j] = dp[(i-1)%2][j-1] + 1;
                }
                else
                {
                    dp[i%2][j] = max(dp[(i-1)%2][j],dp[i%2][j-1]);
                }
            }
        }
        printf("%d\n",n-max(dp[0][n],dp[1][n]));
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值