POJ 1159 DP+滚动数组

Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 57568 Accepted: 19962
Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string “Ab3bd” can be transformed into a palindrome (“dAb3bAd” or “Adb3bdA”). However, inserting fewer than 2 characters does not produce a palindrome.
Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from ‘A’ to ‘Z’, lowercase letters from ‘a’ to ‘z’ and digits from ‘0’ to ‘9’. Uppercase and lowercase letters are to be considered distinct.
Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
Sample Input

5
Ab3bd
Sample Output

2

题意:
有一个字符串。要求问最少添加几个数使得它是一个回文串
题解:
观察后可以发现,这个就是将字符串倒置后与原串求最大公共子列的长度,然后n-公共子列长度就是需要添加字符的个数。马上就写了一个最长子序列的dp,结果交上去一直超内存。 。后来才反应过来用滚动数组优化内存。这个滚动数组有两行,old表示之前求得的那一行结果,now表示现在正在递推的一行。然后操作完一行后对old和now进行异或操作。就把old和now的值换了一下。这样数组就是dp[2][5010],就不会超内存了。PS:这题用short int也能过。

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#define F(i,a,b) for(int i = a;i<=b;i++)
#define FI(i,a,b) for(int i = a;i>=b;i--)
#define SIZE 5000+10

using namespace std;

int dp[2][SIZE];
char a[SIZE];

int solve(int n){
    int old = 0,now = 1;
    memset(dp,0,sizeof(dp));
    F(i,1,n){
        FI(y,n,1){
            int j = n+1-y;
            if(a[i]==a[y]){
                dp[now][j] = dp[old][j-1] + 1;
            }else{
                dp[now][j] = max(dp[old][j],dp[now][j-1]);
            }
        }
        now^=1;
        old^=1;
    }
    return dp[old][n];
}

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF){
        getchar();
        F(i,1,n){
            char c = getchar();
            a[i] = c;
        }
        getchar();
        printf("%d\n",n-solve(n));
    }


    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值