HDU 5386 Cover(暴力)

Cover

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 315    Accepted Submission(s): 102
Special Judge


Problem Description
You have an  nn  matrix.Every grid has a color.Now there are two types of operating:
L x y: for(int i=1;i<=n;i++)color[i][x]=y;
H x y:for(int i=1;i<=n;i++)color[x][i]=y;
Now give you the initial matrix and the goal matrix.There are  m  operatings.Put in order to arrange operatings,so that the initial matrix will be the goal matrix after doing these operatings

It's guaranteed that there exists solution.
 

Input
There are multiple test cases,first line has an integer  T
For each case:
First line has two integer  n , m
Then  n  lines,every line has  n  integers,describe the initial matrix
Then  n  lines,every line has  n  integers,describe the goal matrix
Then  m  lines,every line describe an operating

1color[i][j]n
T=5
1n100
1m500
 

Output
For each case,print a line include  m  integers.The i-th integer x show that the rank of x-th operating is  i
 

Sample Input
  
  
1 3 5 2 2 1 2 3 3 2 1 3 3 3 3 3 3 3 3 3 3 H 2 3 L 2 2 H 3 3 H 1 3 L 2 3
 

Sample Output
  
  
5 2 4 3 1
 

Source
 



想到的话很好做。



#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

struct node
{
    int xx;
    int yy;
    int zz;
} L[501],H[501];

int map1[110][110];
int map2[110][110];
int v[510];
int n,m;

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        memset(v,0,sizeof(v));
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                scanf("%d",&map1[i][j]);
            }
        }
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                scanf("%d",&map2[i][j]);
            }
        }
        int xx,yy;
        char str[5];
        int h = 1;
        int l = 1;
        for(int i=1; i<=m; i++)
        {
            scanf("%s%d%d",str,&xx,&yy);
            if(strcmp(str,"H") == 0)
            {
                H[h].xx = xx;
                H[h].yy = yy;
                H[h].zz = i;
                h++;
            }
            else
            {
                L[l].xx = xx;
                L[l].yy = yy;
                L[l].zz = i;
                l++;
            }
        }
        int a[502];
        int tt = 1;
        for(int ii=1; ii<=n; ii++)
        {
            for(int i=1; i<=n; i++)
            {
                int flag = 0;
                int ans = 0;
                int pp;
                for(int j=1; j<=n; j++)
                {
                    if(ans == 0 && map2[i][j]!=0)
                    {
                        ans = map2[i][j];
                        pp = i;
                    }
                    else if(ans != map2[i][j] && map2[i][j] != 0)
                    {
                        flag = 1;
                        break;
                    }
                }
                if(flag == 0)
                {
                    int pf = 0;
                    for(int j=1; j<h; j++)
                    {
                        if(H[j].xx == pp && H[j].yy == ans)
                        {
                            a[tt] = H[j].zz;
                            v[H[j].zz] = 1;
                            tt++;
                            pf = 1;
                            break;
                        }
                    }
                    if(pf == 1)
                    {
                        for(int j=1; j<=n; j++)
                        {
                            map2[pp][j] = 0;
                        }
                    }
                }
                flag = 0;
                ans = 0;
                for(int j=1; j<=n; j++)
                {
                    if(ans == 0 && map2[j][i]!=0)
                    {
                        ans = map2[j][i];
                        pp = i;
                    }
                    else if(ans != map2[j][i] &&map2[j][i] != 0)
                    {
                        flag = 1;
                        break;
                    }
                }
                if(flag == 0)
                {
                    int pf = 0;
                    for(int j=1; j<l; j++)
                    {
                        if(L[j].xx == pp && L[j].yy == ans)
                        {
                            a[tt] = L[j].zz;
                            v[L[j].zz] = 1;
                            tt++;
                            pf = 1;
                            break;
                        }
                    }
                    if(pf == 1)
                    {
                        for(int j=1; j<=n; j++)
                        {
                            map2[j][pp] = 0;
                        }
                    }
                }
            }
        }
        for(int i=1;i<=m;i++)
        {
            if(v[i] == 0)
            {
                printf("%d ",i);
            }
        }
        for(int i=tt-1;i>=1;i--)
        {
            if(i == 1)
            {
                printf("%d\n",a[i]);
            }
            else
            {
                printf("%d ",a[i]);
            }
       }

    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值