HDU 5441 Travel(并查集)

Travel

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1485    Accepted Submission(s): 528


Problem Description
Jack likes to travel around the world, but he doesn’t like to wait. Now, he is traveling in the Undirected Kingdom. There are  n  cities and  m  bidirectional roads connecting the cities. Jack hates waiting too long on the bus, but he can rest at every city. Jack can only stand staying on the bus for a limited time and will go berserk after that. Assuming you know the time it takes to go from one city to another and that the time Jack can stand staying on a bus is  x  minutes, how many pairs of city  (a,b)  are there that Jack can travel from city  a  to  b  without going berserk?
 

Input
The first line contains one integer  T,T5 , which represents the number of test case.

For each test case, the first line consists of three integers  n,m  and  q  where  n20000,m100000,q5000 . The Undirected Kingdom has  n  cities and  m bidirectional roads, and there are  q  queries.

Each of the following  m  lines consists of three integers  a,b  and  d  where  a,b{1,...,n}  and  d100000 . It takes Jack  d  minutes to travel from city  a  to city  b and vice versa.

Then  q  lines follow. Each of them is a query consisting of an integer  x  where  x  is the time limit before Jack goes berserk.

 

Output
You should print  q  lines for each test case. Each of them contains one integer as the number of pair of cities  (a,b)  which Jack may travel from  a  to  b  within the time limit  x .

Note that  (a,b)  and  (b,a)  are counted as different pairs and  a  and  b  must be different cities.
 

Sample Input
  
  
1 5 5 3 2 3 6334 1 5 15724 3 5 5705 4 3 12382 1 3 21726 6000 10000 13000
 

Sample Output
  
  
2 6 12
 

Source
 



   题意:每2个城市间有一个权值,还有每次询问会给一个权值,城市间的权值小于询问的权值即可以走,问某个人能走多少对城市,注意(a,b),(b,a)算一对不同的城市


#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

int num[21000];
int v[21000];
int n,m,k;
int cnt;
int rt[20010];

struct node {
    int u;
    int v;
    int w;
} q[101000];

struct node1 {
    int x;
    int y;
    int z;
} p[101000];

int cmp1(const void *a,const void *b) {
    struct node1 *aa = (node1*)a;
    struct node1 *bb = (node1*)b;
    return aa->x - bb->x;
}

int cmp3(const void *a,const void *b) {
    struct node *aa = (node*)a;
    struct node *bb = (node*)b;
    return aa->w - bb->w;
}

void add(int u,int v,int z) {
    q[cnt].u = u;
    q[cnt].v = v;
    q[cnt].w = z;
    cnt++;
}

int findx(int x) {
    int r = x;
    while(r!=num[r]) {
        r = num[r];
    }
    int kk = x,j;
    while(kk!=r) {
        j = num[kk];
        num[kk] = r;
        kk = j;
    }
    return r;
}

void bing(int fx,int fy,int x,int y) {
    if(fx!=fy) {
        num[fy] = fx;
    }
}

int main() {
    int T;
    scanf("%d",&T);
    while(T--) {
        scanf("%d%d%d",&n,&m,&k);
        int x,y,z;
        cnt = 0;
        for(int i=0; i<m; i++) {
            scanf("%d%d%d",&x,&y,&z);
            add(x,y,z);
        }
        int x1;
        qsort(q,cnt,sizeof(q[0]),cmp3);
        for(int i=0; i<k; i++) {
            scanf("%d",&x1);
            p[i].z = 0;
            p[i].y = i;
            p[i].x = x1;
        }
        qsort(p,k,sizeof(p[0]),cmp1);
        for(int j=1; j<=n; j++) {
            num[j] = j;
            rt[j] = 0;
            v[j] = 1;
        }
        y = -1;
        int pj = 0;
        for(int i=0; i<k; i++) {
            x = p[i].x;
            for(int j=pj; j<cnt; j++) {
                if(q[j].w>x){
                    break;
                }
                pj = j;
                if(q[j].w>y && q[j].w<=x) {
                    int py = findx(q[j].u);
                    int px = findx(q[j].v);
                    if(px!=py){
                        bing(py,px,q[j].u,q[j].v);
                    int yy = v[py];
                    v[py] += v[px];
                    p[i].z += ((v[py])*(v[py]-1)-(v[px])*(v[px]-1)-(yy*(yy-1)));
                    v[px] = 1;
                    }
                }
            }
            rt[p[i].y] = p[i].z;
            y = p[i].x;
            p[i+1].z = p[i].z;
        }
        for(int j=0;j<k;j++){
            printf("%d\n",rt[j]);
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值