HDU 2899 二分答案

Strange fuction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6881    Accepted Submission(s): 4814


Problem Description
Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 

Sample Input
  
  
2 100 200
 

Sample Output
  
  
-74.4291 -178.8534
#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <set>
#include <cmath>
#include <string>
#include <cstring>
#include <algorithm>
#include <cctype>
#include <queue>
using namespace std;
typedef long long ll;
double x,y;
double val(double x)
{
    return 6*x*x*x*x*x*x*x+8*x*x*x*x*x*x+7*x*x*x+5*x*x-y*x;
}
double solve(double l,double r)
{
    double eps = 1e-7;
    while(l + eps < r)//确定一个终止查找的条件
    {
        double lmid=l+(r-l)/3,rmid=r-(r-l)/3;
        if(val(lmid)<val(rmid))   r=rmid;
        else l=lmid;
    }
    return val(l);
}
int main()
{
    ll t;
    cin>>t;
    while(t--)
    {
        cin>>y;
        printf("%.4f\n", solve(0,100.0));
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值