gcd...

4270: 同源数

Time Limit: 3 Sec   Memory Limit:128 MB
Submit: 743   Solved:99

Description

如果x和y的质因子集合完全相同,那么我们就说他们是同源的。
比如说18 = 2 * 3 2,12 = 3 * 2 2

Input

本题有多组数据(组数 <= 555555)。
每组数据输入形如:
x y
x, y为整数(1 <= x, y <= 1e18)

Output

输出形入:
ans
如果x, y为同源数,那么ans为”Yes”, 不然为”No”.

Sample Input

18 12
2 3

Sample Output

Yes

No

#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <set>
#include <cmath>
#include <string>
#include <cstring>
#include <algorithm>
#include <cctype>
#include <queue>
#include <map>
using namespace std;
typedef long long ll;
ll gcd(ll a,ll b)
{
    return b==0?a:gcd(b,a%b);
}
int main()
{
    ll x,y;
    while(~scanf("%lld%lld",&x,&y))
    {
        int a=0;
        ll d=gcd(x,y),g;
        while(x>1)
        {
            g=gcd(x,d);
            x/=g;
            if(x==1) {a++;break;}
            if(g==1) break;
        }
        while(y>1)
        {
            g=gcd(y,d);
            y/=g;
            if(y==1) {a++;break;}
            if(g==1) break;
        }
        if(a==2) printf("Yes\n");
        else printf("No\n");
    }
    return 0;
}
//令 d=gcd(x,y),将x和y不断与d进行约分。
//若此时x=y=1,那么说明其质因子集合相同。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值