poj3126(bfs)

POJ - 3126
Prime Path
Time Limit: 1000MS Memory Limit: 65536KB 64bit IO Format: %I64d & %I64u

Submit Status

Description
The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don’t know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on… Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.

1033
1733
3733
3739
3779
8779
8179 

The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input
One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output
One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0

Source
Northwestern Europe 2006

码力 太差。。。开始 用int数组 存 字符串 用dfs乱搞。。。没搞出来。。。看了别的 用string 随便一下bfs就出来了。。ym 对于这种 输出最短的条件 就是明显bfs。。。果然别人的题解 就是代码精炼 优雅
还学习 了新东西 pair<>代替结构体。

方法:1.建立一个队列,队列中的元素由string和int构成,string表示当前串,int表示从初始串到当前串的最小转变步数。
2.每次从队列中取出第一个节点,对该节点可行的下一个节点进行扩展并加入队列。
3.搜索的第一个可行解的步骤数即为本问题的解

#include<cstdio>
#include<string>
#include<cstring>
#include<cmath>
#include<queue>
#include<iostream>
using namespace std;
bool prime[10000],book[10000];
int step;
void is_prime()
{
   memset(prime,true,sizeof(prime));
   prime[0]=prime[1]=false;
   int m=sqrt(10000);
   for(int i=2;i<=m;i++)
   {
       if(prime[i])
       {
           for(int j=i+i;j<10000;j+=i)
            prime[j]=false;
       }
   }
   for(int i=0;i<=1000;i++)
    prime[i]=false;
}

string a,b;
int bfs()
{
    queue<pair<string,int> >q;
    while(!q.empty()) q.pop();
    q.push(make_pair(a,0));
    memset(book,false,sizeof(book));
    while(!q.empty())
    {
        pair<string,int>now=q.front();
        q.pop();
        if(now.first==b)
            return now.second;
        for(int i=0;i<=9;i++)
        {
            for(int j=0;j<4;j++)
            {
                if(j==0&&i==0)//稍稍剪枝。
                    continue;
                if(j==3&&i%2==0)
                    continue;
                string tmp=now.first;
                tmp[j]=i+'0';
                int num=(tmp[0]-'0')*1000+(tmp[1]-'0')*100+(tmp[2]-'0')*10+(tmp[3]-'0');
                if(prime[num]&&book[num]==0)
                {
                    book[num]=true;
                    q.push(make_pair(tmp,now.second+1));
                }
                if(tmp==b)
                    return now.second+1;
            }
        }
    }
    return -1;

}

int main()
{
    int T;
    scanf("%d",&T);
    is_prime();
    while(T--)
    {
        cin>>a>>b;
        int o=bfs();
        if(o>=0)
            printf("%d\n",o);
        else
            printf("Imposibble\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值