UVA573 The Snail

 The Snail 

A snail is at the bottom of a 6-foot well and wants to climb to the top.The snail can climb 3 feetwhile the sun is up, but slides down 1 foot at night while sleeping.The snail has a fatigue factorof 10%, which means that on each successive day the snail climbs10% $\times$3 = 0.3 feet less thanit did the previous day. (The distance lost to fatigue is always 10% of thefirst day's climbingdistance.) On what day does the snail leave the well, i.e., what is the firstday during whichthe snail's height exceeds 6 feet? (A day consists of a period of sunlightfollowed by a period ofdarkness.) As you can see from the following table, the snail leaves the wellduring the third day.

DayInitial HeightDistance ClimbedHeight After ClimbingHeight After Sliding
10'3'3'2'
22'2.7'4.7'3.7'
33.7'2.4'6.1'-

Your job is to solve this problem in general. Depending on the parametersof the problem, thesnail will eventually either leave the well or slide back to the bottom ofthe well. (In other words,the snail's height will exceed the height of the well or become negative.)You must find out whichhappens first and on what day.

Input 

The input file contains one or more test cases, each on a line by itself.Each line contains fourintegers H, U, D, and F, separated by a single space. If H= 0 it signals the end of the input;otherwise, all four numbers will be between 1 and 100, inclusive. H is theheight of the well infeet, U is the distance in feet that the snail can climb during the day, D is the distance in feetthat the snail slides down during the night, and F is the fatigue factorexpressed as a percentage.The snail never climbs a negative distance. If the fatigue factor dropsthe snail's climbing distancebelow zero, the snail does not climb at all that day. Regardless of how farthe snail climbed, it always slides D feet at night.

Output 


For each test case, output a line indicating whether the snail succeeded(left the well) or failed(slid back to the bottom) and on what day. Format the output exactly as shown in the example.

Sample Input 

6 3 1 10
10 2 1 50
50 5 3 14
50 6 4 1
50 6 3 1
1 1 1 1
0 0 0 0

Sample Output 

success on day 3
failure on day 4
failure on day 7
failure on day 68
success on day 20
failure on day 2


题目的意思就是蜗牛从井底爬上来,输入分别是井底的深度。每天爬的高度,每天掉的高度。还有每天爬的高度的减弱比例。当爬的高度大于深度(等于不算),就成功,掉到小于0(等于也不算)。减弱比例,像第一的测试数据 10,就是10%.第一天能爬3米,第二天就减弱10% ,爬2.7米,每天减弱比例都是和第一天比较的,也就是每天都是少爬0.3米,但注意小于0后,都按0算。

AC代码如下:


#include<iostream>
using namespace std;

int main ( ) {

	double high,up,down,pow;
	double next;
	double dis = 0;
	int day = 0;
	int temp;
	while(cin >> high >> up >> down >> pow) {
		if (high == 0)
			break;
		pow = ( pow  / 100.0 );
		next = up * pow;
		while (1) {
			dis = dis + up;
			if (dis > high)
				break;
			dis = dis - down;
			if (dis < 0)
				break;
			day++;
			up = up - next;
			if (up < 0)
				up = 0;

		}
		if (dis < 0)
			cout << "failure on day "<< day + 1 <<endl;
		if (dis > high)
		cout << "success on day "<< day + 1 <<endl;
		dis = 0;
		day = 0;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值