UVA442 Matrix Chain Multiplication


 Matrix Chain Multiplication 

Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices.Since matrix multiplication is associative, the order in which multiplications are performed isarbitrary. However, the number of elementary multiplications needed strongly depends on theevaluation order you choose.

For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix.There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).

The first one takes 15000 elementary multiplications, but the second one only 3500.

Your job is to write a program that determines the number of elementary multiplications needed fora given evaluation strategy.

Input Specification

Input consists of two parts: a list of matrices and a list of expressions.

The first line of the input file contains one integer n ( tex2html_wrap_inline28 ), representing the number ofmatrices in the first part. The next n lines each contain one capital letter, specifying the name of thematrix, and two integers, specifying the number of rows and columns of the matrix.

The second part of the input file strictly adheres to the following syntax (given in EBNF):

SecondPart = Line { Line } <EOF>
Line       = Expression <CR>
Expression = Matrix | "(" Expression Expression ")"
Matrix     = "A" | "B" | "C" | ... | "X" | "Y" | "Z"

Output Specification

For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

Sample Input

9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))

Sample Output

0
0
0
error
10000
error
3500
15000
40500
47500
15125


就是判断矩阵相乘要进行多少次乘法。。只有第一个的列,等于第二个的行才能相乘,否则error。

进行乘法的次数就是第一个的行 乘以 第一个的列 乘以第二个的列。。

思路就是找到‘)’就把前面两个矩阵去取来相乘计算次数,‘(’也要取出来,然后把乘完后的新矩阵在push进去。新矩阵的行列就是第一个的行和第二个的列。。

AC代码:

#include<iostream>
#include<stdio.h>
#include<string>
#include<stack>
using namespace std;

struct mat {
	char flag;
	int row;
	int col;
};
int main () {
	stack<char> sta;
	mat mats[100];
	string str;
	int t;
	cin >> t;
	getchar();
	for (int i = 0; i < t ;i++) {
		cin >> mats[i].flag >> mats[i].row >> mats[i].col;
	}
	while (cin >> str) {
		if (str.size() == 1) {
			cout<<"0"<<endl;
			continue;
		}
		int j = t;
		char temp1,temp2;
		int t1,t2;
		int count = 0;
		bool find = true;
		for (int i = 0 ; i < str.size();i++) {
			if (str[i] != ')') {
				sta.push(str[i]);
				continue;
			}
			if (str[i] == ')') {
				temp2 = sta.top();
				sta.pop();
				temp1 = sta.top();
				sta.pop();
				sta.pop();

				t1 = temp1 - 65;
				t2 = temp2 - 65;
				if(mats[t1].col != mats[t2].row) {
					cout << "error"<<endl;
					find = false;
					break;

				}
				else {
					count +=mats[t1].row * mats[t1].col * mats[t2].col;
					mats[j].flag = 65 + j;
					mats[j].row	= mats[t1].row;
					mats[j].col = mats[t2].col;
					sta.push(mats[j].flag);
					j++;
				}

			}
		}
		if (find == true)
			cout << count<<endl;
		find = true;

	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值