uva 442 Matrix Chain Multiplication

原题:
Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices.
Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary.
However, the number of elementary multiplications needed strongly depends on the evaluation order
you choose.
For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix. There are two
different strategies to compute A*B*C, namely (A*B)C and A(B*C).
The first one takes 15000 elementary multiplications, but the second one only 3500.
Your job is to write a program that determines the number of elementary multiplications needed
for a given evaluation strategy.
Input
Input consists of two parts: a list of matrices and a list of expressions.
The first line of the input file contains one integer n (1 ≤ n ≤ 26), representing the number of
matrices in the first part. The next n lines each contain one capital letter, specifying the name of the
matrix, and two integers, specifying the number of rows and columns of the matrix.
The second part of the input file strictly adheres to the following syntax (given in EBNF):
SecondPart = Line { Line }
Line = Expression
Expression = Matrix | “(” Expression Expression “)”
Matrix = “A” | “B” | “C” | … | “X” | “Y” | “Z”
Output
For each expression found in the second part of the input file, print one line containing the word ‘error’
if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one
line containing the number of elementary multiplications needed to evaluate the expression in the way
specified by the parentheses.
Sample Input
9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))
Sample Output
0
0
0
error
10000
error
3500
15000
40500
47500
15125

中文:

给你一堆矩阵,然后给你一个矩阵乘法的顺序,让你计算按照这个顺序计算矩阵乘法,里面要计算多少次?

#include <bits/stdc++.h>

using namespace std;

typedef long long ll;

typedef pair<int,int> pii;

map<char,pii> mc;
int n;
string s;

int main()
{

    ios::sync_with_stdio(false);
    while(cin>>n)
    {
        mc.clear();
        char a;
        int r,c;
        for(int i=1;i<=n;i++)
        {
            cin>>a>>r>>c;
            mc[a]={make_pair(r,c)};
        }
        while(cin>>s)
        {
            int ans=0;
            int flag=0;
            stack<char> sc;
            stack<pii> mat;
            pii p1,p2;
            for(int i=0;i<s.size();i++)
            {
                if(s[i]=='(')
                    sc.push('(');
                if(s[i]==')')
                {
                    p1=mat.top();
                    mat.pop();

                    p2=mat.top();
                    mat.pop();
                    if(p1.first!=p2.second)
                    {
                        flag=1;
                        break;
                    }
                    ans+=p1.second*p1.first*p2.first;
                    mat.push(make_pair(p2.first,p1.second));
                    sc.pop();
                }
                if(s[i]!='('&&s[i]!=')')
                    mat.push(mc[s[i]]);
            }
            if(flag)
                cout<<"error"<<endl;
            else
                cout<<ans<<endl;
        }
    }
    return 0;
}

解答:

小白书的基础题目,主要就是如何处理乘法序列的表达式。

利用两个栈,一个用来存储括号,另一个用来存储矩阵,每次遍历表达式,遇到左括号和矩阵时分别入栈,遇到右括号时候,计算当前栈顶的两个矩阵乘法,再将乘法后的矩阵入栈,如此下来即可。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值