杭电oj-1170-Balloon Comes!

Problem Description
The contest starts now! How excited it is to see balloons floating around. You, one of the best programmers in HDU, can get a very beautiful balloon if only you have solved the very very very... easy problem.
Give you an operator (+,-,*, / --denoting addition, subtraction, multiplication, division respectively) and two positive integers, your task is to output the result. 
Is it very easy? 
Come on, guy! PLMM will send you a beautiful Balloon right now!
Good Luck!
Input
Input contains multiple test cases. The first line of the input is a single integer T (0<T<1000) which is the number of test cases. T test cases follow. Each test case contains a char C (+,-,*, /) and two integers A and B(0<A,B<10000).Of course, we all know that A and B are operands and C is an operator. 
Output
For each case, print the operation result. The result should be rounded to 2 decimal places If and only if it is not an integer.
Sample Input
4
+ 1 2
- 1 2
* 1 2
/ 1 2
Sample Output
3
-1
2

0.50

这道题的题目意思是给你一个数n,代表有n组测试数据,然后接下来的n行有一个字符a和两个整数b,c。字符是加减乘除中的一个,让你输出b和c按a运算的结果。如果结果是小数,保留两位。

思路:这是一道特别水的题,在a为加减乘的时候,最后结果一定是整数,直接输出结果就行,当为除的时候,我们根据b是否能整除c从而判断输出的是整数还是小数。主意加上getchar(),在读入a的时候。

代码如下:

#include <stdio.h>
int main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
        getchar();
        char a;
        int b,c;
        scanf("%c %d %d",&a,&b,&c);
        //对四种运算进行判断
        if(a=='+')
            printf("%d\n",b+c);
        else if(a=='-')
            printf("%d\n",b-c);
        else if(a=='*')
            printf("%d\n",b*c);
        else
        {
            //判断能否整除
            if(b%c==0)
                printf("%d\n",b/c);
            else
            {
                double d;
                d=(double)b/c;
                printf("%.2lf\n",d);
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值