杭电oj-1115-Lifting the Stone

Problem Description
There are many secret openings in the floor which are covered by a big heavy stone. When the stone is lifted up, a special mechanism detects this and activates poisoned arrows that are shot near the opening. The only possibility is to lift the stone very slowly and carefully. The ACM team must connect a rope to the stone and then lift it using a pulley. Moreover, the stone must be lifted all at once; no side can rise before another. So it is very important to find the centre of gravity and connect the rope exactly to that point. The stone has a polygonal shape and its height is the same throughout the whole polygonal area. Your task is to find the centre of gravity for the given polygon. 
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer N (3 <= N <= 1000000) indicating the number of points that form the polygon. This is followed by N lines, each containing two integers Xi and Yi (|Xi|, |Yi| <= 20000). These numbers are the coordinates of the i-th point. When we connect the points in the given order, we get a polygon. You may assume that the edges never touch each other (except the neighboring ones) and that they never cross. The area of the polygon is never zero, i.e. it cannot collapse into a single line. 
Output
Print exactly one line for each test case. The line should contain exactly two numbers separated by one space. These numbers are the coordinates of the centre of gravity. Round the coordinates to the nearest number with exactly two digits after the decimal point (0.005 rounds up to 0.01). Note that the centre of gravity may be outside the polygon, if its shape is not convex. If there is such a case in the input data, print the centre anyway. 
Sample Input
2
4
5 0
0 5
-5 0
0 -5
4
1 1
11 1
11 11
1 11
Sample Output
0.00 0.00

6.00 6.00

这道题的大概意思是让你输入一个数n,然后有n个测试样例,每个样例的开始有一个数m,表示有m个点,接下来的m行给出这些点的坐标,问你由这些点组成的多边形的重心的坐标。

思路:我们知道,求一个三角形的重心坐标,可以用累加点的x坐标和y坐标,然后求平均值,但是这种叠加方法的精度不够。所以需要用另外一种方法,即多边形的重心公式

以三角形为例,这里就不证明了,大家可以去网上找找,很不错的。

代码如下:

#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <string.h>
#include <math.h>
using namespace std;
struct note
{
    double x;
    double y;
};
struct note a[1000010];
//计算三角形的面积
double mianji(note p1,note p2,note p3)
{
    double s=p1.x*p2.y+p2.x*p3.y+p3.x*p1.y-p2.x*p1.y-p3.x*p2.y-p1.x*p3.y;
    return s/2;
}
int main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
        int m;
        scanf("%d",&m);
        for(int i=0;i<m;i++)
            scanf("%lf %lf",&a[i].x,&a[i].y);
        double sum=0;
        double x=0;
        double y=0;
        //将多边形分成很m-2个三角形
        for(int i=2;i<m;i++)
        {

    double s=mianji(a[0],a[i-1],a[i]);
            sum+=s;
            x+=(a[0].x+a[i-1].x+a[i].x)*s;
            y+=(a[0].y+a[i-1].y+a[i].y)*s;
        }
        //求重心坐标
        x=x/(3*sum);
        y=y/(3*sum);
        printf("%.2lf %.2lf\n",x,y);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值