计算几何——HDUOJ 1115 - Lifting the Stone(计算多边形重心 / 多边形面积)

原题


  • Problem Description

There are many secret openings in the floor which are covered by a big heavy stone. When the stone is lifted up, a special mechanism detects this and activates poisoned arrows that are shot near the opening. The only possibility is to lift the stone very slowly and carefully. The ACM team must connect a rope to the stone and then lift it using a pulley. Moreover, the stone must be lifted all at once; no side can rise before another. So it is very important to find the centre of gravity and connect the rope exactly to that point. The stone has a polygonal shape and its height is the same throughout the whole polygonal area. Your task is to find the centre of gravity for the given polygon.

  • Input

    The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer N (3 <= N <= 1000000) indicating the number of points that form the polygon. This is followed by N lines, each containing two integers Xi and Yi (|Xi|, |Yi| <= 20000). These numbers are the coordinates of the i-th point. When we connect the points in the given order, we get a polygon. You may assume that the edges never touch each other (except the neighboring ones) and that they never cross. The area of the polygon is never zero, i.e. it cannot collapse into a single line.

  • Output

    Print exactly one line for each test case. The line should contain exactly two numbers separated by one space. These numbers are the coordinates of the centre of gravity. Round the coordinates to the nearest number with exactly two digits after the decimal point (0.005 rounds up to 0.01). Note that the centre of gravity may be outside the polygon, if its shape is not convex. If there is such a case in the input data, print the centre anyway.

  • Sample Input

    2
    4
    5 0
    0 5
    -5 0
    0 -5
    4
    1 1
    11 1
    11 11
    1 11

  • Sample Output

    0.00 0.00
    6.00 6.00

  • 解题思路:

    【在此感谢杭电刘春英老师的PPT】

    • 在计算几何里,我们知道,△ABC的面积就是“向量AB”和“向量AC”两个向量叉积的绝对值的一半。其正负表示三角形顶点是在右手系还是左手系。
      这里写图片描述

      这里写图片描述

    • 很自然地,我们会想到以 P1为扇面中心,连接P1Pi就得到N-2个三角形,由于凸性,保证这些三角形全在多边形内,那么,这个凸多边形的有向面积:

      Area(总) = ∑(sigma)(Ai) ( i = 1 … N-2 )

      这里写图片描述

    • 那么对于凹多边形:也依然成立,因为叉乘算出来的三角形面积是有方向正负的

    • 我们也可以以多边形内部的一个点为扇心,就可以把多边形剖分成 N个三角形
      这里写图片描述这里写图片描述

    • 把扇心移到多边形以外,直接将扇心(P0)设为原点

    得出多边形的面积公式:

    • 最后!!!!!通过以下公式就可以方便的求出多边形的面积
    • 这里写图片描述

    • 要计算多边形的重心,由于多边形的质量可以看作是平均分布到内部的任何一个区域上
    • 这时候可以通过各个三角形面积总面积上占用的百分比来衡量三角形的质量
    • 这个时候可以算出每个三角形的重心然后通过上面的百分比进行加权平均

      三角形的重心公式:
      这里写图片描述

      多边形的重心公式:
      这里写图片描述

    得出多边形的重心公式:

    • 这里写图片描述

    代码:

    #include <stdio.h>
    struct Point
    {
        double x, y;//hduoj的注意,输入的点必须要double,不要被题目的扯淡迷惑了,wa死我了
    }P[1000001];
    double Cross(Point a, Point b)//叉乘
    {
        return (a.x*b.y - a.y*b.x);
    }
    Point FuncAdd(Point i, Point j)
    {
        Point a;
        a.x = i.x + j.x;
        a.y = i.y + j.y;
        return a;
    }
    Point FuncMultiply(Point i, double j)//乘法
    {
        Point a;
        a.x = i.x*j;
        a.y = i.y*j;
        return a;
    }
    int main()
    {
        int T;
        long long N, i;
        double TotalArea, R_x, R_y;
        Point Sigma, temp;
        scanf("%d", &T);
        while (T--)
        {
            scanf("%lld", &N);
            scanf("%lf%lf", &P[1].x, &P[1].y);
            TotalArea = 0;
            Sigma = { 0,0 };
            for (i = 2; i <= N; i++)
            {
                scanf("%lf%lf", &P[i].x, &P[i].y);
                TotalArea += Cross(P[i], P[i - 1]);
                temp = FuncMultiply(FuncAdd(P[i], P[i - 1]), Cross(P[i], P[i - 1]));
                Sigma.x += temp.x;
                Sigma.y += temp.y;
            }
            TotalArea += Cross(P[1], P[N]);
            temp = FuncMultiply(FuncAdd(P[1], P[N]), Cross(P[1], P[N]));
            Sigma.x += temp.x;
            Sigma.y += temp.y;
            R_x = Sigma.x / TotalArea / 3;
            R_y = Sigma.y / TotalArea / 3;
            if (R_x == -0)R_x = 0;
            if (R_y == -0)R_y = 0;
            printf("%.2lf %.2lf\n", R_x, R_y);
        }
    }
  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值