PAT 甲级 1004 Counting Leaves (DFS)(c++版)(附代码注释)

1004 Counting Leaves (30 分)

原文链接:http://kakazai.cn/index.php/Kaka/Pat/query/id/94

题目

题目链接:https://pintia.cn/problem-sets/994805342720868352/problems/994805521431773184

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M(<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

题意分析

  • 题意

从家族谱中数出每一代没有孩子的家族成员的个数。

  • 分析

要判断每层的叶子个数,需要知道每个点所在的层数,以及它是否有孩子。

知识点与坑点

  • 知识点

1)DFS

  • 坑点

1)

一、DFS

算法思路

1 用变长数组存储非叶结点的孩子数。若某结点的变长数组容量为0,证明它是叶结点

2 深度遍历每个点,并计算它所在的层数

3 深度遍历同时,累加每层的叶子个数

代码-c++版
#include <iostream>
#include<cstdio>
#include<vector>
using namespace std;
const int maxn = 100 ;	//最多有99个结点 

/* 关键变量 */ 
vector<int> child[maxn]; //存储结点的所有孩子
int v[maxn];	//记录结点是否被访问过 
int depth[maxn];	//记录树的第i层的叶子结点个数
int maxd = 0;	//记录树的最大层数

/* DFS:遍历结点,更新最大的层数,并记录每层叶结点的个数*/
void DFS(int cur, int d) {    //cur为当前遍历的结点,d为cur所在的层数 
    if (d > maxd)maxd = d;   //若cur所在的层数更大,则更新
    if (child[cur].size() == 0) {  //cur为叶结点,更新数量 
        depth[d]++;    
        return; 
    }
    //若当前结点cur为非叶结点,则继续遍历它的孩子结点
    for (int i = 0; i < child[cur].size(); i++) {
        int id = child[cur][i];
        DFS(id, d + 1);
    }
}


int main(){
	
	int n,e; 
    scanf("%d %d", &n, &e);
    
    /* 用变长数组存储每个非叶结点的孩子 */ 
    for (int i = 0; i < e; i++) {
        int in1, in2,k;
        scanf("%d %d", &in1, &k);
        for (int j = 0; j < k; j++) {
            scanf("%d", &in2);
            child[in1].push_back(in2);
        }
    }
	
	/*用DFS遍历所有结点,并记下每层叶子结点数*/
    DFS(1, 0);	//根结点01,其位于0层 
    
	/*打印[0,maxd]层的叶子结点个数*/
    printf("%d", depth[0]);
        for (int i = 1; i <= maxd; i++) {
            printf(" %d", depth[i]);
    }
	
	return 0;
}
代码-python版

待补充

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值