Cash Machine

Cash Machine
Time Limit: 1000MS Memory Limit: 10000K
   

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

cash N n1 D1 n2 D2 ... nN DN 

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash. 

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash. 

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

Source

/**
   0-1背包之多重背包

   有N种物品,每种价值为wi,给定一个最大价值数,问由给的N种物品能凑齐最接近最大价值数的价值是多少(不大于最大价值)。

   方法如下:
**/
#include <iostream>
#include <cstdio>
#include <cstring>

#define Mem(a,x) memset(a,x,sizeof(a));
#define maxn 100010
using namespace std;

int num[11];
int val[11];
int dp[maxn];
int cont[maxn];
int N;
int maxv;

void init()
{
    Mem(num,0);
    Mem(val,0);
    Mem(dp, 0);
}
/***********第一种方法**********
思路:   设dp[i]为能得到的最靠近i的值,则有dp[i]<=i
     举例说明,如果只能凑齐价值为3的东西,呢么dp[5]=dp[4]=dp[3]=3.

     因此,我们在枚举每种wi的同时,再枚举从wi到maxv(最大值)的状态,
     则转移方程为dp[i]=dp[i-wi]+wi,转移条件是:dp[i]<dp[i-wi]+wi ,
     这样就可以充分利用前面算出的dp值了。

     但是,还需要保证wi的数量不能超过给定的数量,因此,在每次枚举wi时,
     需要一个与当前状态dp[i]对应的计数器,用于记录当前状态已经用了多少个wi。
     同样,每次进行dp[i]的转移时,计数器count[i]=count[i-wi]+1.
void DP()
{
    for(int i=0;i<N;i++)
    {
        Mem(cont,0);//cont是当前价值的每个状态的计数器,每次更换wi时,cont需要置零
        for(int j=val[i];j<=maxv;j++)
            if(dp[j]<dp[j-val[i]]+val[i]&&cont[j-val[i]]<num[i])
            {
                dp[j]=dp[j-val[i]]+val[i];//转移方程
                cont[j]=cont[j-val[i]]+1;//计数器转移
            }
    }
    printf("%d\n",dp[maxv]);//answer为dp[max]
}

/***********第二种方法**********
思路:
     dp[i]表示价值为i的物品是否凑得出来,能凑出来则为1,否则为0
     由于题目中给定的物品不止有一种,因此,我们需要用合适的方式对这些物品进行分割,
     分割成一件一件新的物品,将本题转换为0-1背包。
     所有分割后的物品总价值为wi*numi,并且,分割后,任意几块的组合可以得到wi*k,0<=k<=numi
     因此,采用1,2,4,8,。。。,这种分割方式,最后一块如果无法满足2的指数,那就单独成块。
     如此:
********************************/
int w[maxn];
void deal()//分隔物品
{
    int n=0;
    Mem(w,0);
    for(int i=0; i<N; i++)
    {
        for(int j=1; j<=num[i]; j*=2)
        {
            w[n++]=j*val[i];//形成新的物品呢
            num[i]-=j;//分割后,从原来中减去
        }
        if(num[i]>0)//最后一部分单独成块
            w[n++]=num[i]*val[i];
    }
    w[n]=-1;//表示分隔完毕
}
void DP()
{
    deal();
    dp[0]=1;
    for(int i=0; w[i]!=-1; i++)//经典一维01背包
    {
        for(int j=maxv; j>=w[i]; j--)
            if(dp[j-w[i]])//状态转移条件
                dp[j]=dp[j-w[i]];//转移
    }
    for(int i=maxv; i>=0; i--)
        if(dp[i])
        {
            printf("%d\n",i);
            break;
        }
}

int main()
{
    while(~scanf("%d%d",&maxv,&N))
    {
        init();
        for(int i=0; i<N; i++)
            scanf("%d%d",&num[i],&val[i]);
        DP();
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值