动态规划之Cash Machine

 

Cash Machine

Description

A Bank plans toinstall a machine for cash withdrawal. The machine is able to deliverappropriate @ bills for a requested cash amount. The machine uses exactly Ndistinct bill denominations, say Dk, k=1,N, and for each denomination Dk themachine has a supply of nk bills. For example, 

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each,and 5 bills of @10 each. 

Call cash the requested amount of cash the machine should deliver and write aprogram that computes the maximum amount of cash less than or equal to cashthat can be effectively delivered according to the available bill supply of themachine. 

Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ maystand for dollar, euro, pound etc. 

Input

The program inputis from standard input. Each data set in the input stands for a particulartransaction and has the format: 

cash N n1 D1 n2 D2 ... nN DN 

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <=10 is the number of bill denominations and 0 <= nk <= 1000 is the numberof available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. Whitespaces can occur freely between the numbers in the input. The input data arecorrect. 

Output

For each set ofdata the program prints the result to the standard output on a separate line asshown in the examples below. 

Sample Input

735 3 4 125  6 5  3 350

633 4 500 30  6 100  1 5  01

735 0

0 3 10 100  10 50  10 10

Sample Output

735

630

0

0

Hint

The first data setdesignates a transaction where the amount of cash requested is @735. Themachine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3bills of @350. The machine can deliver the exact amount of requested cash. 

In the second case the bill supply of the machine does not fit the exact amountof cash requested. The maximum cash that can be delivered is @630. Notice thatthere can be several possibilities to combine the bills in the machine formatching the delivered cash. 

In the third case the machine is empty and no cash is delivered. In the fourthcase the amount of cash requested is @0 and, therefore, the machine delivers nocash.

 

题目解读:题意很简单。就是用给定的数组合出不超过cash的数

 

解题思路:由于逻辑很简单,下面直接给出可行代码:

 

 

 

#include<iostream>

using namespace std;

 

struct Node

{

         intn;

         intd;

};

 

int main()

{

         Nodenode[15];

         intcash;

         intN;

         boolkey[100010];

         while(cin>>cash)

         {

                   for(inti=0;i<100010;i++)

                            key[i]=false;

                   cin>>N;

                   if(N==0)

                   {

                            cout<<0<<endl;

                            continue;

                   }

                   for(inti=1;i<=N;i++)

                   {

                            cin>>node[i].n>>node[i].d;

                   }

                   if(cash==0)

                   {

                            cout<<0<<endl;

                            continue;

                   }

                   key[0]=true;

                   intmax=0;

                   inttem;

                   for(inti=1;i<=N;i++)

                   {

                            for(intj=max;j>=0;j--)

                            {

                                     if(key[j])

                                     {

                                               for(intk=1;k<=node[i].n;k++)

                                               {

                                                        tem=j+k*node[i].d;

                                                        if(tem>cash)

                                                                 continue;

                                                        key[tem]=true;

                                                        if(tem>max)

                                                                 max=tem;

                                               }

                                     }

                            }

                   }

                   cout<<max<<endl;

         }

         return0;

}

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值