Japan

Japan
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17409 Accepted: 4685

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output: 
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5

Source

/**树状数组**/
/***********************************************************************
按照题目所给的信息,首先要知道,从同一点出发的高速路是没有交点的。
    其次,每添加一条公路时,必须保证与它相交的公路都已经添加完毕,
    然后,思路:
以east的点为起点,west的点为终点,
先将公路存储,然后按照起点从小到大排列,如果起点相同,按照公路终点的
远近从大到小排列,这样添加公路时,就可以保证能穿过的都已经添加了,
ans就是每添加一条公路时,在之前添加的,且能被穿过的公路都已经被添加了。
    但是,
当添加1 4时,
需要更新sum[1][1],sum[1][2],sum[1][3]....但树状数组是更新sum[1][5]....
所以,
     添加公路时,west应转换,变成m+1-west,这样就符合树状数组的更新规则了.
************************************************************************/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;
#define maxn 1010
#define lowbit(x) (x)&(-x)
#define f(x) (m+1)-(x)
//转换函数
struct Shw//superhighway
{
    int e,w;
}s[maxn*maxn];//公路
int n,m,k;
long long sum[maxn];//实际上,经过east的排序后,第一维可以去掉了

void Insert(int x)//树状数组插入
{
    while(x<=m)
    {
        sum[x]+=1;
        x+=lowbit(x);
    }
}
long long Query(int x)//树状数组查询
{
    long long ans=0;
    while(x>0)
    {
        ans+=sum[x];
        x-=lowbit(x);
    }
    return ans;
}

bool cmp(Shw a,Shw b)//排序函数
{
    if(a.e!=b.e) 
        return a.e<b.e;
    else
        return a.w<b.w;
}
void read()
{
    memset(sum,0,sizeof(sum));
    memset(s,0,sizeof(s));
    for(int i=0;i<k;i++)
    {
        int a,b;
        scanf("%d%d",&a,&b);
        s[i].e=a;
        s[i].w=f(b);
    }
    sort(s,s+k,cmp);
}

long long deal()
{
    long long ans=0;
    int j=0;
    for(int i=0;i<k;i++)
    {
        ans+=Query(s[i].w-1);
        if(i>0&&s[i].e==s[i-1].e)//同一点出发的公路,要将起点的交点减去
            j++;
        else
            j=0;
        ans-=j;
        Insert(s[i].w);
    }
    return ans;
}

int main()
{
    int icas,i=1;
    scanf("%d",&icas);
    for(i=1;i<=icas;i++)
    {
        scanf("%d%d%d",&n,&m,&k);
        read();
        printf("Test case %d: %lld\n",i,deal());
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值