1048. 数字加密(20)/YHF/2016.11.22

1048. 数字加密(20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

本题要求实现一种数字加密方法。首先固定一个加密用正整数A,对任一正整数B,将其每1位数字与A的对应位置上的数字进行以下运算:对奇数位,对应位的数字相加后对13取余——这里用J代表10、Q代表11、K代表12;对偶数位,用B的数字减去A的数字,若结果为负数,则再加10。这里令个位为第1位。

输入格式:

输入在一行中依次给出A和B,均为不超过100位的正整数,其间以空格分隔。

输出格式:

在一行中输出加密后的结果。

输入样例:
1234567 368782971
输出样例:

3695Q8118

#include <iostream> 
#include<algorithm>
#include<sstream>     
#include   <string>  
using namespace std;
int main()
{
	int i, j, temp, haha = 0;
	string s1;
	string s2;
	string s3;
	string p = { 'J','Q','K' };
	cin >> s1 >> s2;
	i = 0;
	while (s1[i] == '0') 
		i++;
	s1 = s1.substr(i, s1.length());

	i = 0;
	while (s2[i] == '0')
		i++;
	s2 = s2.substr(i, s2.length());
	if (s1.length() < s2.length()) {
		swap(s1, s2); haha = 1;
	}
	//cout << s1 <<" "<< s2;
	s3 = s1;
	for (i = s1.length() - 1; i >= 0; i--) {
		j = s2.length() - s1.length() + i;
		if (j < 0) {
			j = 1;
			s2[j] = '0';
		}
		if ((s1.length() - i) % 2 == 1) {
			temp = ((s1[i] - '0') + (s2[j] - '0')) % 13;
			if (temp >= 10)
				s3[i] = p[temp - 10];
			else
				s3[i] = temp + '0';
		}
		else if (haha == 1) {
			temp = s1[i] - s2[j];
			if (temp < 0)
				temp += 10;
			s3[i] = temp + '0';
		}
		else {
			temp = s2[j] - s1[i];
			if (temp < 0)
				temp += 10;
			s3[i] = temp + '0';
		}

	}
		cout << s3;
}

感想:

1.注意,当B位数小于A的时候,高位默认为0(不知道是怎么默认的,反正我是被坑了有一个小时)

2.奇数偶数位是从个位开始算了

注意到这两点直接死算就出来了

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值