1015. Reversible Primes (20)/YHF/2016.12.1

1015. Reversible Primes (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes

No

#include<iostream>
#include<string>
#include<algorithm>
#include<sstream>
#include<queue>

using namespace std;
bool isprime(int a){
	if (a == 1)
		return false;
	if (a == 2)
		return true;
	if ( a%2==0)
		return false;
	for (int i = 3; i <= a / 2 + 1; i+=2) {
		if (a%i == 0)
			return false;
	}
	return true;
}
int main() {
	int temp0, temp1,temp2;
	vector<int> v1;
	vector<int>::iterator it;
	v1.clear();
	while (1) {
		cin >> temp0;
		temp2 = temp0;
		if (temp0 < 0)
			break;
		cin >> temp1;
		while (temp0 != 0) {
			v1.push_back(temp0%temp1);
			temp0 /= temp1;
		}
		int j = 0;
		 for (it = v1.begin(); it != v1.end(); it++) {
			 temp0 += (*it)*pow(temp1*1.0,v1.size()-j++ -1);
		 }
		 v1.clear();
		 if (isprime(temp0) && isprime(temp2))
			 cout << "Yes" << endl;
		 else
			 cout << "No" << endl;
	}
}

感想:练手题,注意点是1不是素数,进制转换切记要熟悉

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值