PAT (Advanced Level) Practice 1031 Hello World for U (20)(20 分)

1031 Hello World for U (20)(20 分)

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n~1~ characters, then left to right along the bottom line with n~2~ characters, and finally bottom-up along the vertical line with n~3~ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n~1~ = n~3~ = max { k| k <= n~2~ for all 3 <= n~2~ <= N } with n~1~

  • n~2~ + n~3~ - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

题解1:

题目要求每行字符的个数要大于等于每列字符的个数。

行列之间的字符计数是有重合的,左下角和右下角的字符计算了2次。为了计算和输出方便,这里考虑左右下角的两个字符只算在行字符中,不算列字符。

以上述规则为前提,如果直接把总字符个数除以3得到列字符数,剩下作为行字符数,那么在总字符数能被3整除的时候,行字符数比真正的列字符数小1。比如n=9, collum=9/3=3, row=9/3+9%3=3, 这时候实际上1列有4个字符,1行只有3个字符。

因此这里把总字符数-1带入计算,比如n=9, collum=(9-1)/3=2, row=(9-1)/3+(9-1)%3+1;(不能用row=(9-1)/3+9%3替代)。

最后先输出前collum行列字符,再输出最后一行row个行字符。

源代码1:

#include <iostream>
#include <string>
using namespace std;
int main()
{
  string s;
  int count=0,l,b;
  cin>>s;
  count=s.size()-1;
  l=count/3;
  b=l+count%3+1;
  for(int i=0;i<l;i++)
  {
  cout<<s[i];
  for(int j=1;j<b-1;j++)
  cout<<" ";
  cout<<s[count-i]<<endl;
  }
  for(int i=l;i<=count-l;i++)
  cout<<s[i];
  return 0;
}

题解2:

重点在于计算行列的值。因为左右下角的字符被重复计算2次,所以也可以先总字符数+2,再运算。这时候计算的行列值,就是真正的行列值。比如n=9, collum=(9+2)/3=3,row=(9+2)/3+(9+2)%3=5.

源代码2:

#include <iostream>
#include <string>
using namespace std;
int main()
{
  string s;
  int count=0,l,b;
  cin>>s;
  count=s.size()+2;
  l=count/3;
  b=l+count%3;
  for(int i=0;i<l-1;i++)
  {
  cout<<s[i];
  for(int j=1;j<b-1;j++)
  cout<<" ";
  cout<<s[count-i-3]<<endl;
  }
  for(int i=l-1;i<=count-l-2;i++)
  cout<<s[i];
  return 0;
}

这几种方法没有好坏之分,只要能够正确输出,具体行列值取多少是自由选择的。题目只给了2种容易正确的样例,需要学会自己挖掘,遍历各种情况,找到多条正确的路中的一条即可。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值