A+B for Matrices

46 篇文章 0 订阅
46 篇文章 0 订阅
题目描述:

    This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.

输入:

    The input consists of several test cases, each starts with a pair of positive integers M and N (≤10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines follow, each contains N integers in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.

    The input is terminated by a zero M and that case must NOT be processed.

输出:

    For each test case you should output in one line the total number of zero rows and columns of A+B.

样例输入:
2 2
1 1
1 1
-1 -1
10 9
2 3
1 2 3
4 5 6
-1 -2 -3
-4 -5 -6
0
样例输出:
1
5
 
  
import java.util.ArrayList;
import java.util.List;
import java.util.Scanner;
 
public class Main{
    public static void main(String[] args) {
        Scanner scanner = new Scanner(System.in);
         
        int rows = 0, columns = 0;
        int result = 0;
        int count = 0;
         
        while( scanner.hasNext() ){
             
            rows = scanner.nextInt();
             
            if(rows <= 0) break;
             
            columns = scanner.nextInt();
             
             
             
            List<Integer> matriceA = new ArrayList<Integer>();
            List<Integer> matriceB = new ArrayList<Integer>();
            List<Integer> matriceC = new ArrayList<Integer>();
             
             
            for (int i = 0; i < rows; i++) {
                for (int j=0; j < columns; j++) {
                    matriceA.add(scanner.nextInt());
                }
            }
             
            for (int i = 0; i < rows; i++) {
                for (int j=0; j < columns; j++) {
                    matriceB.add(scanner.nextInt());
                }
            }
             
            for (int i = 0; i < rows*columns; i++) {
                matriceC.add( matriceA.get(i) + matriceB.get(i));
            }
             
             
            for (int i = 0; i < columns; i++) {
                result = matriceC.get(i);
                for (int j = 1; j < rows; j++) {
                    result = result + matriceC.get(i + j*columns);
                }
                if(result == 0){
                    count++;
                }
            }
             
             
            for (int i = 0; i < rows*columns; i=i+columns) {
                result = matriceC.get(i);
                for (int j = 1; j < columns; j++) {
                    result = result + matriceC.get(i + j);
                }
                if(result == 0){
                    count++;
                }
            }
             
            System.out.println(count);
            count = 0;
             
        }
        scanner.close();
    }
 
}
 
/**************************************************************
    Problem: 1001
    User: yihukurama
    Language: Java
    Result: Accepted
    Time:900 ms
    Memory:18848 kb
****************************************************************/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值