PAT甲级1001java解题

PAT甲级java解题

题目1001: Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.
Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input:
-1000000 9
Sample Output:
-999,991
代码:

import java.io.BufferedReader;
import java.io.IOException;
import java.util.Scanner;
import java.io.InputStreamReader;
public class Main    {
        public static void main(String[] args) {
                    Scanner sc = new Scanner(System.in); 
                    int a = sc.nextInt();           
                    int b = sc.nextInt();           
                    Integer sum = a+b;          
                      //对于特例无需格式化处理           
                    if (sum < 1000 && sum > -1000)               
                        System.out.println(sum);            
                    else                
                    	System.out.println(format(sum));       
                     }               
         private static String format(Integer num)        {
                    //使用stringbuffer对每个数字及逗号进行连接           
                    StringBuffer sb = new StringBuffer();           
                    String str = num.toString();            
                    boolean isNegative = (num<0);            
                    if(isNegative) {               
                         str = str.substring(1);               
                         sb.append("-");           
                     }           
                     int length = str.length();            
                     for(int i = 0;i<length;i++) {        
                            //对于特定的位置加入“,”,注意末尾无论如何不能加“,”                											  
                          if((length-1-i)%3 == 0&&i!=length-1) {                   
                          sb.append(str.charAt(i));                    
                          sb.append(",");                
                      	  } else                    
                       	sb.append(str.charAt(i));           
                      }            
                        return sb.toString();       
          	 }   
	}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值