三分搜索

【转载】http://blog.csdn.net/angelniu1024/article/details/11966649

二分法作为分治中最常见的方法,适用于单调函数,逼近求解某点的值。但是当函数是凸性函数或者凹性函数时,二分法就不再适用,这时我们便用到的三分法。


如上图所示,类似二分的定义,mid = (left + right)/ 2,midmid = (mid + right)/ 2,如果mid靠近极值点,则 right = midmid,否则 left = mid。

double Calc(Type a)  
{  
     /* 根据题目的意思计算 */  
}  
   
void Solve()  
{  
     double left, right;  
     double mid, midmid;  
     double mid_value, midmid_value;  
     left = MIN; right = MAX;  
     while (left + EPS < right)  
     {  
            mid = (left + right) / 2;  
            midmid = (mid + right) / 2;  
            mid_value = Calc(mid);  
            midmid_value = Calc(midmid);  
            // 假设求解最大极值.  
            if (mid_value >= midmid_value) right = midmid;  
            else left = mid;  
     }  
}  
例题: http://acm.hdu.edu.cn/showproblem.php?pid=2438

Turn the corner

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1734    Accepted Submission(s): 646


Problem Description
Mr. West bought a new car! So he is travelling around the city.

One day he comes to a vertical corner. The street he is currently in has a width x, the street he wants to turn to has a width y. The car has a length l and a width d.

Can Mr. West go across the corner?

 

Input
Every line has four real numbers, x, y, l and w.
Proceed to the end of file.
 

Output
If he can go across the corner, print "yes". Print "no" otherwise.
 

Sample Input
  
  
10 6 13.5 4 10 6 14.5 4
 

Sample Output
  
  
yes no
 

Source
 

分析


汽车拐弯问题,给定X, Y, l, w判断是否能够拐弯。首先当X或者Y小于w,那么一定不能。
其次我们发现随着角度θ的增大,最大高度h先增长后减小,即为凸性函数,可以用三分法来求解。

这里的Calc函数需要比较繁琐的推倒公式:
s = l * cos(θ) + w * sin(θ) - x;
h = s * tan(θ) + w * cos(θ);
其中s为汽车最右边的点离拐角的水平距离, h为里拐点最高的距离, θ范围从0到90。



代码:
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
#include<math.h>
#include<cstdlib>
using namespace std;
#include<stdio.h>
#define PI 3.1415926
#define EPS 1e-8
#define N 3000+10
double x,y,l,w;
double Calc(double angle)
{
    double s = l * cos(angle) + w * sin(angle) - x;
    double h = s * tan(angle) + w * cos(angle);
    return h;
}
double solve()
{
    double left, right;
    double mid, midmid;
    double mid_value, midmid_value;
    left = 0.0;
    right = PI/2;
    while (left + EPS < right)
    {
        mid = (left + right) / 2;
        midmid = (mid + right) / 2;
        mid_value = Calc(mid);
        midmid_value = Calc(midmid);
        if (mid_value >= midmid_value) right = midmid;
        else left = mid;
    }
    return mid_value;
}
int main()
{
    while(scanf("%lf%lf%lf%lf",&x,&y,&l,&w)!=EOF)
    {
        double ans=solve();
        if(ans<=y)
            printf("yes\n");
        else printf("no\n");
    }

    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值