Slim Span(并查集+kruskal函数)

本题是一个图论的题目

1.运用到了并查集的代码(并查集的代码已经很成熟了,可以直接进行套用)

2.运用到了kruskal算法(主要用来求最小生成树的,本题通过kruskal算法中排序后的结构体生成树权值大小找到对应的形成树时的最大数和最小数从而求得结果)

两个问题

1.初始化时:i=1开始和i=0开始要全文对应

2.既然是求最小,需要把所有的可能得到的值都考虑在内(每求一次务必进行初始化,防止相互影响)

I - Slim Span
Time Limit:5000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

Given an undirected weighted graph G, you should find one of spanning trees specified as follows.

The graph G is an ordered pair (VE), where V is a set of vertices {v1v2, …, vn} and E is a set of undirected edges {e1e2, …, em}. Each edge e∈ E has its weight w(e).

A spanning tree T is a tree (a connected subgraph without cycles) which connects all the n vertices with n − 1 edges. The slimness of a spanning tree T is defined as the difference between the largest weight and the smallest weight among the n − 1 edges of T.

 
Figure 5: A graph  G and the weights of the edges

For example, a graph G in Figure 5(a) has four vertices {v1v2v3v4} and five undirected edges {e1e2e3e4e5}. The weights of the edges arew(e1) = 3, w(e2) = 5, w(e3) = 6, w(e4) = 6, w(e5) = 7 as shown in Figure 5(b).

 
Figure 6: Examples of the spanning trees of  G

There are several spanning trees for G. Four of them are depicted in Figure 6(a)~(d). The spanning tree Ta in Figure 6(a) has three edges whose weights are 3, 6 and 7. The largest weight is 7 and the smallest weight is 3 so that the slimness of the tree Ta is 4. The slimnesses of spanning trees TbTc and Td shown in Figure 6(b), (c) and (d) are 3, 2 and 1, respectively. You can easily see the slimness of any other spanning tree is greater than or equal to 1, thus the spanning tree Td in Figure 6(d) is one of the slimmest spanning trees whose slimness is 1.

Your job is to write a program that computes the smallest slimness.

Input

The input consists of multiple datasets, followed by a line containing two zeros separated by a space. Each dataset has the following format.

nm 
a1b1w1
  
ambmwm

Every input item in a dataset is a non-negative integer. Items in a line are separated by a space. n is the number of the vertices and m the number of the edges. You can assume 2 ≤ n ≤ 100 and 0 ≤ m ≤ n(n − 1)/2. ak and bk (k = 1, …, m) are positive integers less than or equal to n, which represent the two vertices vak and vbk connected by the kth edge ekwk is a positive integer less than or equal to 10000, which indicates the weight of ek. You can assume that the graph G = (VE) is simple, that is, there are no self-loops (that connect the same vertex) nor parallel edges (that are two or more edges whose both ends are the same two vertices).

Output

For each dataset, if the graph has spanning trees, the smallest slimness among them should be printed. Otherwise, −1 should be printed. An output should not contain extra characters.

Sample Input

4 5
1 2 3
1 3 5
1 4 6
2 4 6
3 4 7
4 6
1 2 10
1 3 100
1 4 90
2 3 20
2 4 80
3 4 40
2 1
1 2 1
3 0
3 1
1 2 1
3 3
1 2 2
2 3 5
1 3 6
5 10
1 2 110
1 3 120
1 4 130
1 5 120
2 3 110
2 4 120
2 5 130
3 4 120
3 5 110
4 5 120
5 10
1 2 9384
1 3 887
1 4 2778
1 5 6916
2 3 7794
2 4 8336
2 5 5387
3 4 493
3 5 6650
4 5 1422
5 8
1 2 1
2 3 100
3 4 100
4 5 100
1 5 50
2 5 50
3 5 50
4 1 150
0 0

Sample Output

1
20
0
-1
-1
1
0
1686
50

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#define inf 99999999       //此处的最大数用作标记是否存在形成的树的最大值和最小值差的最小值
using namespace std;

int n,m;
const int MAX_E=5050;      //注意分清MAX_E与MAX_R
const int MAX_R=110;       //MAX_E表示输入内容的结构体,描述边的结构体,MAX_R表示表示节点的最大值

struct edge
{
    int u,v,cost;          //表示结构体组成(用作表示边)
};

edge es[MAX_E];

int father[MAX_R];//父亲
int _rank[MAX_R];//树的高度

//初始化n个元素
void init(int n)
{
    for(int i=1;i<=n;i++)    //注意此处i=1;或者i=0;需要与全文相对应的,对应统一
    {
        father[i]=i;
        _rank[i]=1;
    }
}

//查询树的根
int find(int x)
{
    if(father[x]==x)
    {
        return x;
    }
    else
    {
        return father[x]=find(father[x]);    //此处是路径压缩问题,将所有的子节点直接连接点根节点上,并回溯根节点
    }
}


//合并x和y的集合
void unite(int x,int y)
{
    x=find(x);                              //找到他们的根节点,让根节点与新的结合,
    y=find(y);
    if(x==y)
        return;
    if(_rank[x]<_rank[y])
    {
        father[x]=y;
    }
    else
    {
        father[y]=x;
        if(_rank[x]==_rank[y])
            _rank[x]++;
    }
}

bool same(int x,int y)
{
    return find(x)==find(y);
}

bool cmp(edge a,edge b)
{
    return a.cost<b.cost;     //有关结构体排序时需要用到的函数备注
}

int kruskal()
{
    int temp=inf;
    sort(es+1,es+m+1,cmp);  //根据权值排序
    int sum,res;
    for(int j=1;j<=m;j++)   //本来以为排序后只需要计算前几个数的差值和后几个数的差值就可以算出最大与最小事实应该利用双重循环
    {                       //避免中间几个数字相邻很近的被忽略)
        init(n);            //每次调用时均需初始化,以免上一次形成的树对这次产生影响
        sum=0,res=inf;      //对用到边的条数和结果的初始化的最小值
        for(int i=j;i<=m;i++)
    {
        if(!same(es[i].u,es[i].v))
        {
            unite(es[i].u,es[i].v);
            sum++;
            if(sum==n-1)
            {
                res=es[i].cost-es[j].cost;
            }
        }
    }

    if(res<temp)      //每次比较,找出最小
    {
        temp=res;
    }
    }
    if(temp==inf)  //若没有最小,不存在最小数(可能边不能构成最小生成树)
        temp=-1;
    return temp;  //结果返回
}

int main()
{
    while(~scanf("%d %d",&n,&m))
    {
        if(n==0&&m==0)
            break;

        for(int i=1;i<=m;i++)
        {
            scanf("%d %d %d",&es[i].u,&es[i].v,&es[i].cost);
        }

        if(m<n-1)  //如果边数不够构成最小生成树,则输出-1
        {
            printf("-1\n");
            continue;
        }
        printf("%d\n",kruskal());

    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值