Least Common Multiple


Least Common Multiple

2016年9月27日 19:16 新浪博客 删除

Description

The least common multiple (LCM) of a set of positive integersis the smallest positive integer which is divisible by all thenumbers in the set. For example, the LCM of 5, 7 and 15 is105. 

Input

Input will consist of multiple problem instances. The first line ofthe input will contain a single integer indicating the number ofproblem instances. Each instance will consist of a single line ofthe form m n1 n2 n3 ... nm where m is the number of integers in theset and n1 ... nm are the integers. All integers will be positiveand lie within the range of a 32-bitinteger. 

Output

For each problem instance, output a single line containing thecorresponding LCM. All results will lie in the range of a 32-bitinteger. 

Sample Input

2
3 5 7 15
6 4 10296 936 1287 792 1

Sample Output

105
10296

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;

int gcd(int m,int n)
{
    if(n<m)
    {
        int temp=n;
        n=m;
        m=temp;
    }
    int r=n%m;
    while(r)
    {
        n=m;
        m=r;
        r=n%m;
    }
    return m;
}

int main()
{
    int n,m,t,ans;
    scanf("%d",&n);
    while(n--)
    {
        ans=1;
        scanf("%d",&m);
        while(m--)
        {
            scanf("%d",&t);
            ans=t/gcd(ans,t)*ans;//避免数据溢出,先除后乘
        }
        printf("%d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值