输入一个字符串和一个非负整数N,要求将字符串循环左移N次。
输入格式:
输入在第1行中给出一个不超过100个字符长度的、以回车结束的非空字符串;第2行给出非负整数N。
输出格式:
在一行中输出循环左移N次后的字符串。
输入样例:
Hello World!
2
输出样例:
llo World!He
所谓大道至简,九九归一,什么花里胡哨的全部干掉,直接输出!(赖皮解法)
代码如下:
#include <iostream>
#include <string>
using namespace std;
int main()
{
string str;
getline(cin, str);
int leng = str.length();
int n;
cin >> n;
while (n >= leng)
n %= leng;//因为n有可能大于字符串长度,所以干掉重复片段,让n小于leng
for (int i = n; i < leng; i++)
cout << str[i];
for (int i = 0; i < n; i++)
cout << str[i];
return 0;
}