HDU - 1863 - 畅通工程 - 克鲁斯

畅通工程

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 29257    Accepted Submission(s): 12841


Problem Description
省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。经过调查评估,得到的统计表中列出了有可能建设公路的若干条道路的成本。现请你编写程序,计算出全省畅通需要的最低成本。
 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出评估的道路条数 N、村庄数目M ( < 100 );随后的 N 
行对应村庄间道路的成本,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间道路的成本(也是正整数)。为简单起见,村庄从1到M编号。当N为0时,全部输入结束,相应的结果不要输出。
 

Output
对每个测试用例,在1行里输出全省畅通需要的最低成本。若统计数据不足以保证畅通,则输出“?”。
 

Sample Input
  
  
3 3 1 2 1 1 3 2 2 3 4 1 3 2 3 2 0 100
 

Sample Output
  
  
3 ?
 

Source
 

Recommend

lcy



连着两道模板题,手写克鲁斯卡尔应该没问题了。。。。。



#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<vector>
#include<set>
#include<queue>
#include<map>
#include<stack>
#define max3(x, y, z) max((x), max((y), (z)))
#define min3(x, y, z) min((x), min((y), (z)))
#define pb push_back
#define mp make_pair
#define LL long long
using namespace std;

const int N = 111;

struct Edge
{
    int u;
    int v;
    int w;
}edges[N * N];


int n, m;
int ne[N];
int cnt;

bool cmp(Edge a, Edge b)
{
    return a.w < b.w;
}

void ini()
{
    for(int i = 0; i <= n; i ++){
        ne[i] = i;
    }
}

int fi(int x)
{
    int t = x;

    while(t != ne[t]){
        t = ne[t];
    }
    while(x != t){
        int q = ne[x];
        ne[x] = t;
        x = q;
    }

    return t;
}

void join(int x, int y)
{
    ne[x] = y;
}

LL kru()
{
    LL ans = 0;

    ini();
    for(int i = 0; i < m; i ++){
        int a = fi(edges[i].u);
        int b = fi(edges[i].v);
        if(a != b){
            join(a, b);
            ans += edges[i].w;
            cnt ++;
            if(cnt >= n - 1) break;
        }
    }
    /*cout << ans << endl;
    cout << cnt << endl;
    cout << n << endl;*/
    if(cnt != n - 1) ans = -1;

    return ans;
}

int main()
{
    LL ans;

    while(scanf("%d%d", &m, &n) == 2){
        if(m == 0) break;
        cnt = ans = 0;
        for(int i = 0; i < m; i ++){
            scanf("%d%d%d", &edges[i].u, &edges[i].v, &edges[i].w);
        }
        sort(edges, edges + m, cmp);
        ans = kru();
        if(ans == -1) printf("?\n");
        else printf("%lld\n", ans);
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值