暑期集训—day1—hdu 4190— Distributing Ballot Boxes—二分,优先队列

槽点有点多。。。论一上午怎么给小白讲完高精度加减乘除以及二分。。一股绝望的气息扑面而来



四道题   1~3分别是高精度加乘除   不贴了(高精度加法刚开始被我写坏了我会说?)

直接第四题吧



Distributing Ballot Boxes

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1789    Accepted Submission(s): 921


Problem Description
Today, besides SWERC'11, another important event is taking place in Spain which rivals it in importance: General Elections. Every single resident of the country aged 18 or over is asked to vote in order to choose representatives for the Congress of Deputies and the Senate. You do not need to worry that all judges will suddenly run away from their supervising duties, as voting is not compulsory.
The administration has a number of ballot boxes, those used in past elections. Unfortunately, the person in charge of the distribution of boxes among cities was dismissed a few months ago due to nancial restraints. As a consequence, the assignment of boxes to cities and the lists of people that must vote in each of them is arguably not the best. Your task is to show how efficiently this task could have been done.
The only rule in the assignment of ballot boxes to cities is that every city must be assigned at least one box. Each person must vote in the box to which he/she has been previously assigned. Your goal is to obtain a distribution which minimizes the maximum number of people assigned to vote in one box.
In the first case of the sample input, two boxes go to the fi rst city and the rest to the second, and exactly 100,000 people are assigned to vote in each of the (huge!) boxes in the most efficient distribution. In the second case, 1,2,2 and 1 ballot boxes are assigned to the cities and 1,700 people from the third city will be called to vote in each of the two boxes of their village, making these boxes the most crowded of all in the optimal assignment.
 

Input
The fi rst line of each test case contains the integers N (1<=N<=500,000), the number of cities, and B(N<=B<=2,000,000), the number of ballot boxes. Each of the following N lines contains an integer a i,(1<=a i<=5,000,000), indicating the population of the i th city. 
A single blank line will be included after each case. The last line of the input will contain -1 -1 and should not be processed.
 

Output
For each case, your program should output a single integer, the maximum number of people assigned to one box in the most efficient assignment.
 

Sample Input
  
  
2 7 200000 500000 4 6 120 2680 3400 200 -1 -1
 

Sample Output
  
  
100000 1700


算是回归ACM的第一道正是题目吧,1A了感觉还是很不错的,虽然我的方法耗时有点多,题意就是有n个城市,每个城市都有各自的人口,给你m个篮子,保证大于等于城市数目,每个城市至少要分有一个篮子去放人(反正大概就是这么个意思),问怎么个分篮子法让人口最多的那个篮子的人数最少。 先让每个城市都有一个篮子,这样目前每个篮子里的人口数就是城市的人口,用优先队列+剩余篮子的循环,找出每个循环中篮子人口最多的的篮子属于的城市,再分给它一个篮子
就OK了。刚开始用了结构体数组,结果内存开不下。。。只好。。。make_pair大发好。。。刚开始还以为运算符重载被我写坏了,,加注释找bug找了蛮久的。


#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<set>
#include<map>
#include<vector>
#include<queue>
#define pb push_back
#define mp make_pair
#define LL long long
#define max3(x, y, z) max((x), max((y), (z)))
#define min3(x, y, z) min((x), min((y), (z)))
using namespace std;

const int N = 500005;

int main()
{
    int n, m;
    int ma[N];

    while(scanf("%d%d", &n, &m) == 2){
        if(n == -1 && m == -1) break;
        priority_queue< pair<int, pair<int, int> > > Q;    /// <篮子里的人数, <篮子里的人所在的城镇编号,   篮子里的人所在的城目前有多少个篮子>  >
        for(int i = 0; i < n; i ++){
            scanf("%d", &ma[i]);
            Q.push(mp(ma[i], mp(i, 1)));
        }
        int t = m - n;
        for(int i = 1; i <= t; i ++){
            int a = Q.top().first;
            int b = Q.top().second.first;
            int c = Q.top().second.second;      ///得到篮子里人最多的数据
            Q.pop();
            c ++;
            int t = ma[b] / c;          ///往那个城镇加篮子
            if(t * c != ma[b]){         ///有可能人没法完全均分到每个篮子,最多的需要+1s
                t ++;
            }
            Q.push(mp(t, mp(b, c)));    ///再入队
        }
        printf("%d\n", Q.top().first);
    }

    return 0;
}



后来发现这题可以直接二分答案,但是感觉还是有点悬乎。。。

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;

int num[500100],n,m;
int judge(int x)
{
    int s=0;
    for(int i=1;i<=n;i++)
    {
        s+=num[i]/x;
        if(num[i]%x!=0) s++;//注意所有人都得投票
    }    
    if(s>m) return 0;
    return 1;
}
int main()
{
    int i,j;
    while(~scanf("%d%d",&n,&m))
    {
        if(n==-1&&m==-1) break;
        int L=1,R=-1;
        for(i=1;i<=n;i++)
        {
            scanf("%d",&num[i]);
            if(num[i]>R) R=num[i];
        }
        while(L<R)
        {
            int mid=(L+R)/2;
            if(!judge(mid))L=mid+1;
            else R=mid;        
        }
        printf("%d\n",R);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值