Distributing Ballot Boxes (优先队列)

Today, besides SWERC'11, another important event is taking place in Spain which rivals it in importance: General Elections. Every single resident of the country aged 18 or over is asked to vote in order to choose representatives for the Congress of Deputies and the Senate. You do not need to worry that all judges will suddenly run away from their supervising duties, as voting is not compulsory. 
 The administration has a number of ballot boxes, those used in past elections. Unfortunately, the person in charge of the distribution of boxes among cities was dismissed a few months ago due to nancial restraints. As a consequence, the assignment of boxes to cities and the lists of people that must vote in each of them is arguably not the best. Your task is to show how efficiently this task could have been done. 
 The only rule in the assignment of ballot boxes to cities is that every city must be assigned at least one box. Each person must vote in the box to which he/she has been previously assigned. Your goal is to obtain a distribution which minimizes the maximum number of people assigned to vote in one box. 
 In the first case of the sample input, two boxes go to the fi rst city and the rest to the second, and exactly 100,000 people are assigned to vote in each of the (huge!) boxes in the most efficient distribution. In the second case, 1,2,2 and 1 ballot boxes are assigned to the cities and 1,700 people from the third city will be called to vote in each of the two boxes of their village, making these boxes the most crowded of all in the optimal assignment.

Input

The fi rst line of each test case contains the integers N (1<=N<=500,000), the number of cities, and B(N<=B<=2,000,000), the number of ballot boxes. Each of the following N lines contains an integer a i,(1<=a i<=5,000,000), indicating the population of the i th city. 
 A single blank line will be included after each case. The last line of the input will contain -1 -1 and should not be processed.

Output

For each case, your program should output a single integer, the maximum number of people assigned to one box in the most efficient assignment.

Sample Input

2 7
200000
500000

4 6
120
2680
3400
200

-1 -1

Sample Output

100000
1700

题意:某个国家要进行选举,求怎样分配投票箱才能使每个城市最少有一个投票箱,求每个投票里投的票数的最大值最小。

思路:我用的是优先队列,当然用二分更好,我就讲讲优先队列吧。因为每个城市最少要有一个投票箱,首先我就将所有的城市入的信息入队列,即这个城市放的人数,投票箱数,那么就可以求出每个投票箱分配的最大人数,然后我以每个投票箱分配的最大人数为重载条件,将这个投票箱子中最大的人数放在队首。放完后,就要看剩下的投票箱怎么分配了,因此我们每次只拿出一个投票箱,把它分给队首,同时就能求出此时的最大人数,再把它放入队列即可。最后只需取队首,输出其最大人数。

代码如下:

#include<cstdio>
#include<cstring>
#include<queue>
#define N 500010
using namespace std;
long long num[N];
struct node
{
    int x,y,z;  //x为城市的人口,y为分给这个城市的投票箱数,z为这个城市的投票箱内的最大人数
    bool operator < (const node &a)const //以最大人数为重载条件
    {
        return a.z>z;
    }
};
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m)&&(n!=-1||m!=-1))
    {
        priority_queue<node>Q;
        node p,q;
        for(int i=0; i<n; i++)  //把n个城市入队列
        {
            scanf("%d",&q.x);
            q.y=1;
            q.z=q.x;
            Q.push(q);
        }
        int s=m-n;//剩余投票箱数
        while(s--)
        {
            p=Q.top();
            Q.pop();
            q.x=p.x;
            q.y=p.y+1;  //投票箱数+1
            if(q.x%q.y==0)  //求最大人数
                q.z=q.x/q.y;  
            else
                q.z=q.x/q.y+1;
            Q.push(q);  //入队列
        }
        p=Q.top();
        printf("%d\n",p.z);
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值