A Bug's LifeA Bug's Life

A Bug's Life

Time Limit : 15000/5000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 19   Accepted Submission(s) : 9
Problem Description
Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 

Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
 

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
 

Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
 

Sample Input
  
  
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output
  
  
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!
Hint
Huge input,scanf is recommended.
 
题意:每 给出一对男女关系,判断是否存在同性恋关系。

思路:并查集的关系判断法,0表示同类,1表示不同类。如果输人的这对关系在同一集合,但与根的关系相同,则矛盾(有 bugs

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
struct node
{
	int p;
	int r;
};
int n , m , flag;
int cases = 1;
node Set[2010];
void init()
{
	for(int i = 1; i <= n; i ++)
	{
		Set[i].p = i;
		Set[i].r = 0;
	}
	flag = 0;
}

int findfather(int x)
{
	if(x == Set[x].p) return x;
	int t = findfather(Set[x].p);
	Set[x].r = (Set[x].r + Set[Set[x].p].r)%2;
	Set[x].p = t;
	return t;
}

int union_ab(int x , int y )
{
	int fx = findfather(x);
	int fy = findfather(y);
	if(fx != fy)
	{
		Set[fx].p = fy;
		Set[fx].r = (Set[x].r + Set[y].r + 1)%2;
	}
}
int main()
{
	int t;
	int x , y;
	scanf("%d",&t);
	while(t --)
	{
		scanf("%d%d",&n,&m);
		init();
		for(int i = 0; i < m; i ++)
		{
			scanf("%d%d",&x,&y);
			if(findfather(x) != findfather(y))
			{
				union_ab(x , y);
			}
			else
			{
				if(Set[x].r == Set[y].r)
				    flag = 1;
			}
		}
		printf("Scenario #%d:\n",cases++);
		if(flag) printf("Suspicious bugs found!\n\n");
		else
		     printf("No suspicious bugs found!\n\n");
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
概要介绍:本门课程属于“Java分布式中间件大汇聚实战”系列课程,主要介绍了企业级项目中真实的应用场景的实现及主流的Java核心技术栈(Redis、RabbitMQ、Spring AOP、Redisson、ZooKeeper…)的实战等等。除此之外,还介绍了如何基于Redis设计并实战一款点赞系统(点赞、取消点赞、排行榜、用户中心、文章点赞用户列表…)可以说技术干货甚多,不仅可以巩固企业级应用系统的开发实战能力,相信在面试、跳槽涨薪方面也能带来相应的帮助!课程内容:传说中的金三银四、面试跳槽涨薪季已经来临,Debug特地为大家准备了一系列跟面试、跳槽、巩固核心技术栈相关的课程,本门课程属于第一季,其中的内容包括企业级项目中真实的应用场景实战、面试相关的技术点分享、主流的Java技术栈(Undertow、Redis、RabbitMQ、Spring AOP、Redisson、ZooKeeper…)实战等等。除此之外,我们还基于Redis设计并实战了一款点赞系统,可以说技术干货甚多。在课程的最后,Debug给大家整理了一份最新的面向BAT大厂招聘 ~ 2020年程序猿最新的Java面试题(附带目录和答案),希望对各位小伙伴的成长有所帮助!值得一提的是,本季课程实战的应用场景包括“日志记录”、“邮件发送”、“通告消息通知”、“短信验证码失效验证”、“会员到期自动提醒/到期前N天自动提醒”以及“点赞系统”的设计与实战,其大纲如下所示:其中,涉及到的技术栈包括Spring Boot2.0、Mybatis、Undertow、Redis、RabbitMQ、Redisson、Spring AOP、 Java8…下面罗列出本门课程重点介绍的价格应用案例以及业务场景的实现流程图!(1)基于Spring的消息驱动模型实现日志的异步记录:(2)基于消息中间件RabbitMQ的消息队列实现日志的异步记录:(3)基于缓存中间件Redis的订阅发布机制实现商户公告消息通知:(4)基于Redis的Key失效与定时任务实现实现短信验证码的过期失效验证:其他核心、典型的应用案例和业务场景的实战可以详细参考“课程目录”!除此之外,我们还基于缓存中间件Redis设计并实战实现了点赞系统中的点赞功能模块,下面罗列出其中涉及到的相关功能模块的实战流程图:其课程收益如下所示:
FileZilla Server 0.9.14a是FileZilla的一个服务器版本。这个版本存在一些bug,以下是一些常见的bug及解决方法: 1. 崩溃:在某些情况下,FileZilla Server 0.9.14a可能会因为一些内部错误而崩溃。要解决这个问题,可以尝试升级到最新版本的FileZilla Server,通常会修复此问题。 2. 无法连接:有时客户端可能无法连接到FileZilla Server。首先,请确保服务器正在运行,并且服务器的端口正确配置。如果问题仍然存在,可以尝试重新启动服务器,并检查防火墙设置。 3. 用户权限问题:有些用户可能报告无法正确访问或修改文件的权限。这可能是由于FileZilla Server的配置错误导致的。建议仔细检查用户的权限设置,确保用户具有所需的访问权限。 4. 传输中断:在某些情况下,传输可能会意外中断,导致文件传输不成功。这可能是由于网络连接不稳定或配置错误引起的。建议使用稳定的网络连接,并确保服务器的传输设置正确。 5. 界面错误:FileZilla Server 0.9.14a的界面可能偶尔出现错误或未响应。这可能是由于软件本身的问题。建议尝试重新启动FileZilla Server,并确保计算机的操作系统和其他软件都是最新版本。 总结来说,FileZilla Server 0.9.14a存在一些已知的bug,但大多数情况下可以通过更新到最新版本、检查配置设置或重启服务器来解决。在遇到问题时,还可以参考FileZilla的官方论坛或在线文档,以获得更多帮助和支持。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值