A Bug's LifeA Bug's Life

A Bug's Life

Time Limit : 15000/5000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 19   Accepted Submission(s) : 9
Problem Description
Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 

Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
 

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
 

Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
 

Sample Input
  
  
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output
  
  
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!
Hint
Huge input,scanf is recommended.
 
题意:每 给出一对男女关系,判断是否存在同性恋关系。

思路:并查集的关系判断法,0表示同类,1表示不同类。如果输人的这对关系在同一集合,但与根的关系相同,则矛盾(有 bugs

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
struct node
{
	int p;
	int r;
};
int n , m , flag;
int cases = 1;
node Set[2010];
void init()
{
	for(int i = 1; i <= n; i ++)
	{
		Set[i].p = i;
		Set[i].r = 0;
	}
	flag = 0;
}

int findfather(int x)
{
	if(x == Set[x].p) return x;
	int t = findfather(Set[x].p);
	Set[x].r = (Set[x].r + Set[Set[x].p].r)%2;
	Set[x].p = t;
	return t;
}

int union_ab(int x , int y )
{
	int fx = findfather(x);
	int fy = findfather(y);
	if(fx != fy)
	{
		Set[fx].p = fy;
		Set[fx].r = (Set[x].r + Set[y].r + 1)%2;
	}
}
int main()
{
	int t;
	int x , y;
	scanf("%d",&t);
	while(t --)
	{
		scanf("%d%d",&n,&m);
		init();
		for(int i = 0; i < m; i ++)
		{
			scanf("%d%d",&x,&y);
			if(findfather(x) != findfather(y))
			{
				union_ab(x , y);
			}
			else
			{
				if(Set[x].r == Set[y].r)
				    flag = 1;
			}
		}
		printf("Scenario #%d:\n",cases++);
		if(flag) printf("Suspicious bugs found!\n\n");
		else
		     printf("No suspicious bugs found!\n\n");
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值