Pick-up sticks

Pick-up sticks

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1944    Accepted Submission(s): 730


Problem Description
Stan has n sticks of various length. He throws them one at a time on the floor in a random way. After finishing throwing, Stan tries to find the top sticks, that is these sticks such that there is no stick on top of them. Stan has noticed that the last thrown stick is always on top but he wants to know all the sticks that are on top. Stan sticks are very, very thin such that their thickness can be neglected.
 

Input
Input consists of a number of cases. The data for each case start with 1 ≤ n ≤ 100000, the number of sticks for this case. The following n lines contain four numbers each, these numbers are the planar coordinates of the endpoints of one stick. The sticks are listed in the order in which Stan has thrown them. You may assume that there are no more than 1000 top sticks. The input is ended by the case with n=0. This case should not be processed. 
 

Output
For each input case, print one line of output listing the top sticks in the format given in the sample. The top sticks should be listed in order in which they were thrown. 
The picture to the right below illustrates the first case from input.
 

Sample Input
  
  
5 1 1 4 2 2 3 3 1 1 -2.0 8 4 1 4 8 2 3 3 6 -2.0 3 0 0 1 1 1 0 2 1 2 0 3 1 0
 

Sample Output
  
  
Top sticks: 2, 4, 5. Top sticks: 1, 2, 3.
 

Source
 
线段相交: 每 读人一个就判断是否在前面木棍的上面,是,就删除前面的。

代码如下:

#include <iostream>
#include <cstdio>
#include <vector>
using namespace std;

struct point
{
    double x , y ;
};

struct line
{
    int num ;
    point s , e;
};

vector<line>sticks;

int n;

double xmulti(point a , line b)
{
    return (a.x-b.s.x)*(b.e.y-b.s.y)-(b.e.x-b.s.x)*(a.y-b.s.y);
}
bool inter(line a , line b)
{
    if(min(a.s.x , a.e.x)< max(b.s.x,b.e.x)&&
       min(b.s.x , b.e.x)< max(a.s.x,a.e.x)&&
       min(b.s.y , b.e.y)< max(a.s.y,a.e.y)&&
       min(a.s.y , a.e.y)< max(b.s.y,b.e.y)&&
       xmulti(a.s , b)*xmulti(a.e , b)<0&&
       xmulti(b.s , a)*xmulti(b.e , a)<0)
        return true;
    else
        return false;
}
int main()
{
    while(scanf("%d",&n),n)
    {
        line temp;
        sticks.clear();
        for(int i = 0; i < n; i ++)
        {
            scanf("%lf %lf %lf %lf",&temp.s.x,&temp.s.y,&temp.e.x,
                  &temp.e.y);
            temp.num = i+1;
            for(int j = (int)sticks.size()-1; j >=0; j --)
            {
                if(inter(temp , sticks[j]))
                    sticks.erase(sticks.begin()+j);
            }
            sticks.push_back(temp);
        }
        printf("Top sticks:");
        for(int i = 0; i < (int)sticks.size(); i ++)
        {
                printf(" %d",sticks[i].num);
                if(sticks[i].num == n)
                    printf(".");
                else
                    printf(",");
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值