05-树7. File Transfer (25)

05-树7. File Transfer (25)

时间限制
150 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

We have a network of computers and a list of bi-directional connections. Each of these connections allows a file transfer from one computer to another. Is it possible to send a file from any computer on the network to any other?

Input Specification:

Each input file contains one test case. For each test case, the first line contains N (2<=N<=104), the total number of computers in a network. Each computer in the network is then represented by a positive integer between 1 and N. Then in the following lines, the input is given in the format:

I c1 c2  

where I stands for inputting a connection between c1 and c2; or

C c1 c2    

where C stands for checking if it is possible to transfer files between c1 and c2; or

S

where S stands for stopping this case.

Output Specification:

For each C case, print in one line the word "yes" or "no" if it is possible or impossible to transfer files between c1 and c2, respectively. At the end of each case, print in one line "The network is connected." if there is a path between any pair of computers; or "There are k components." where k is the number of connected components in this network.

Sample Input 1:
5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S
Sample Output 1:
no
no
yes
There are 2 components.
Sample Input 2:
5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S
Sample Output 2:
no
no
yes
yes
The network is connected.
思路:典型的并查集问题,关键问题是搜索效率的提高。
采用两种方法:1.按秩合并---何头课程中有讲到,将较小的高度的集合并到大集合中,这样不会增加树的高度,只有在高度相同的时候树高度会加1;
                     2.路径压缩---在查找根结点的时候顺便把他的“孙子辈”都直接连到他上面
TIP:更详细的分析可自行搜索维基百科---并查集.
#include<iostream>
using namespace std;

int *x;//定义全局变量可以在调用函数时少用一个参数,小代码会显得简洁,不适合大型代码

int FindRoot(int item);
void Union(int num1, int num2);

int main(int argc, char *argv[])
{	
		int MaxSize;
		cin >> MaxSize;
		x = new int[MaxSize + 1];
		//MakeSet
		for (int i = 0; i <= MaxSize; i++)
			x[i] = i;
		while (1)
		{
			char order;
			cin >> order;
			if ('S' == order)
				break;
			int num1, num2;
			cin >> num1 >> num2;
			if ('I' == order)
				Union(num1, num2);
			if ('C' == order)
			{
				if (FindRoot(num1) == FindRoot(num2))
					cout << "yes" << endl;
				else
					cout << "no" << endl;
			}
		}

		int cnt = 0;
		for (int i = 1; i <= MaxSize; i++)
		{
			if (x[i] == i)
				cnt++;
		}
		if (1 == cnt)
			cout << "The network is connected." << endl;
		else
			cout << "There are " << cnt << " components." << endl;

	system("pause");
	return 0;
}

int FindRoot(int item)
{
	if (item != x[item])
		x[item] = FindRoot(x[item]);//路径压缩
	return x[item];	
}

void Union(int num1, int num2)
{
	int root1, root2;
	root1 = FindRoot(num1);
	root2 = FindRoot(num2);
	if (root1 != root2)
	{
		if (root1 < root2)
			x[root2] = root1;
		else
			x[root1] = root2;//按秩合并
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值