1007 Maximum Subsequence Sum

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K ;numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

题意分析 :建立数组把序列的数字全部储存在数组中,对序列进行遍历,依次累加,当和为负的时候,讲左边的位置移到下一个位置,将和归为零,当和为正的时候继续加上后面的数字。记录下最大值的时候,左边和右边的位置,方便输出对应的数字。

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cmath>
using namespace std;
int Numbers[10001];

int main(){
    int N,temp,Sum,Left,Right,MaxLeft,MaxRight;//N是数字个数,temp获取当前的数字,
    //left和right存储当前的范围,MaxLeft和MaxRight记录当前最大
    int MaxSum;
    scanf("%d",&N);
    Left=Right=MaxLeft=MaxRight=0;
    Sum=MaxSum=0;
    for(int i=0;i<N;i++){
        scanf("%d",&temp);
        Numbers[i]=temp;
        Sum=Sum+temp;
        if(i==0){
            MaxSum=Numbers[0];//初始化最大值,将第一个数字赋值给它
        }
        if(temp==0&&Sum>0){//当遇到0,并且当前和为正的时候,0是无意义的不需要放入最大序列中,直接跳过
        }
        else if(temp==0&&MaxSum<0){//当遇到0时,之前的数字之和都是小雨零,则0是最大数,需要记录下来
            MaxSum=0;
            Sum=0;
            Left=i;
            Right=i;
            MaxLeft=i;
            MaxRight=i;
        }
        else if(Sum<0){//当和小于0时,应该跳过这段序列,它会影响到后面的序列之和
            Left=i+1;
            Right=i+1;
            Sum=0;
        }
        else if(Sum>MaxSum){//出现和更大的序列时,将该序列存储下来,并替换最大值的记录
            Right=i;
            MaxLeft=Left;
            MaxRight=Right;
            MaxSum=Sum;
        }
    }
    if(MaxSum>=0){//对结果进行输出
        printf("%d %d %d",MaxSum,Numbers[MaxLeft],Numbers[MaxRight]);
    }
    else{
        printf("0 %d %d",Numbers[0],Numbers[N-1]);
    }

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值