1009 Product of Polynomials (25分)

1009 Product of Polynomials (25分)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

 题意解析:通过结构体,将两个多项式的信息储存起来。将两个多项式相乘,结果储存到DOUBLE数组当中(便于访问)。当两个多项式相乘完毕后,最后再遍历非零的数(我在最初的计算过程中并未考虑到多项式相乘正负相反想加刚好等0的情况,和结果为符的情况),最后遍历就不用统计结果为零的情况,切记统计结果为负的情况,第一个检测点就有负数的情况。

#include<iostream>
#include<cstdio>
#include<cstdlib>
using namespace std;

struct Number{
    int n;
    double a;
}A[11],B[11];
double C[2002]={0};
int main(){
    int K1,n,K2,c1,minnum,N;
    double a,c2;
    minnum=2001,N=0;
    scanf("%d ",&K1);
    for(int i=0;i<K1;i++){
        scanf("%d %lf",&n,&a);
        A[i].n=n;
        A[i].a=a;
    }
    scanf("%d ",&K2);
    for(int i=0;i<K2;i++){
        scanf("%d %lf",&n,&a);
        B[i].n=n;
        B[i].a=a;
    }
    for(int i=0;i<K1;i++){
        for(int j=0;j<K2;j++){
            c1=A[i].n+B[j].n;
            c2=A[i].a*B[j].a;
            C[c1]=C[c1]+c2;
        }
    }
    for(int i=0;i<2002;i++){
        if(C[i]!=0){
                N++;
            }
    }
    printf("%d",N);
    for(int i=2002;i>=0;i--){
        if(C[i]!=0){
            printf(" %d %.1f",i,C[i]);
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值