ZOJ 3329 One Person Game(概率DP、求期望)

题目链接:点击打开链接



One Person Game

Time Limit: 1 Second       Memory Limit: 32768 KB       Special Judge

There is a very simple and interesting one-person game. You have 3 dice, namely Die1Die2 and Die3Die1 has K1 faces. Die2 has K2 faces. Die3 has K3 faces. All the dice are fair dice, so the probability of rolling each value, 1 to K1K2K3 is exactly 1 / K1, 1 / K2 and 1 / K3. You have a counter, and the game is played as follow:

  1. Set the counter to 0 at first.
  2. Roll the 3 dice simultaneously. If the up-facing number of Die1 is a, the up-facing number of Die2 is b and the up-facing number of Die3 is c, set the counter to 0. Otherwise, add the counter by the total value of the 3 up-facing numbers.
  3. If the counter's number is still not greater than n, go to step 2. Otherwise the game is ended.

Calculate the expectation of the number of times that you cast dice before the end of the game.

Input

There are multiple test cases. The first line of input is an integer T (0 < T <= 300) indicating the number of test cases. Then T test cases follow. Each test case is a line contains 7 non-negative integers nK1K2K3abc (0 <= n <= 500, 1 < K1K2K3 <= 6, 1 <= a <= K1, 1 <= b <= K2, 1 <= c <= K3).

Output

For each test case, output the answer in a single line. A relative error of 1e-8 will be accepted.

Sample Input

2
0 2 2 2 1 1 1
0 6 6 6 1 1 1

Sample Output

1.142857142857143
1.004651162790698

Author:  CAO, Peng
Source:  The 7th Zhejiang Provincial Collegiate Programming Contest
One Person Game

Time Limit: 1 Second       Memory Limit: 32768 KB       Special Judge

There is a very simple and interesting one-person game. You have 3 dice, namely Die1Die2 and Die3Die1 has K1 faces. Die2 has K2 faces. Die3 has K3 faces. All the dice are fair dice, so the probability of rolling each value, 1 to K1K2K3 is exactly 1 / K1, 1 / K2 and 1 / K3. You have a counter, and the game is played as follow:

  1. Set the counter to 0 at first.
  2. Roll the 3 dice simultaneously. If the up-facing number of Die1 is a, the up-facing number of Die2 is b and the up-facing number of Die3 is c, set the counter to 0. Otherwise, add the counter by the total value of the 3 up-facing numbers.
  3. If the counter's number is still not greater than n, go to step 2. Otherwise the game is ended.

Calculate the expectation of the number of times that you cast dice before the end of the game.

Input

There are multiple test cases. The first line of input is an integer T (0 < T <= 300) indicating the number of test cases. Then T test cases follow. Each test case is a line contains 7 non-negative integers nK1K2K3abc (0 <= n <= 500, 1 < K1K2K3 <= 6, 1 <= a <= K1, 1 <= b <= K2, 1 <= c <= K3).

Output

For each test case, output the answer in a single line. A relative error of 1e-8 will be accepted.

Sample Input

2
0 2 2 2 1 1 1
0 6 6 6 1 1 1

Sample Output

1.142857142857143
1.004651162790698

Author:  CAO, Peng
Source:  The 7th Zhejiang Provincial Collegiate Programming Contest

题意:有三个色子,分别有k1,k2,k3面,投掷这三个色子,如果他们面朝上的数分别是a,b,c,分数归为0,否则加上这三个数的和,分数超过n,游戏     结束,否则继续投色子,求投掷色子次数的期望。起始分数为0。
思路:设dp[i]为从当前数位i达到目标状态需要投色子的次数,pk为投掷k分的概率,p0为回到0的概率
    则dp[i]=∑(pk*dp[i+k])+dp[0]*p0+1;
    都和dp[0]有关系,而且dp[0]就是我们所求,为常数
      设dp[i]=A[i]*dp[0]+B[i];
      代入上述方程右边得到:
      dp[i]=∑(pk*A[i+k]*dp[0]+pk*B[i+k])+dp[0]*p0+1
      =(∑(pk*A[i+k])+p0)dp[0]+∑(pk*B[i+k])+1;
      明显A[i]=(∑(pk*A[i+k])+p0)
      B[i]=∑(pk*B[i+k])+1
      先递推求得A[0]和B[0].
      那么  dp[0]=B[0]/(1-A[0]);

代码:
#include<stdio.h>
#include<string.h>
int main()
{
    int t,n,k1,k2,k3,a,b,c,i,j,h;double dp[800],A[800],B[800],p[100];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d%d%d%d%d",&n,&k1,&k2,&k3,&a,&b,&c);
         memset(p,0,sizeof(p));
        double p0=1.0/(k1*k2*k3);
        for(i=1;i<=k1;i++)
        for(j=1;j<=k2;j++)
        for(h=1;h<=k3;h++)
        if(i!=a||j!=b||h!=c)
        p[i+j+h]+=1.0/(k1*k2*k3);
        memset(A,0,sizeof(A));memset(B,0,sizeof(B));
        for(i=n;i>=0;i--)
        {
            A[i]=p0;B[i]=1;
            for(j=1;j<=k1+k2+k3;j++)
            {
                A[i]+=p[j]*A[i+j];
                B[i]+=p[j]*B[i+j];
            }
        }
        printf("%.16lf\n",B[0]/(1-A[0]));
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值