poj 3685(二分查找第K大的值)

Time Limit: 6000MS Memory Limit: 65536KB 64bit IO Format: %lld & %llu

 Status

Description

Given a N × N matrix A, whose element in the i-th row and j-th column Aij is an number that equals i2 + 100000 × i + j2 - 100000 × j + i × j, you are to find the M-th smallest element in the matrix.

Input

The first line of input is the number of test case.
For each test case there is only one line contains two integers, N(1 ≤ N ≤ 50,000) and M(1 ≤ M ≤ N × N). There is a blank line before each test case.

Output

For each test case output the answer on a single line.

Sample Input

12

1 1

2 1

2 2

2 3

2 4

3 1

3 2

3 8

3 9

5 1

5 25

5 10

Sample Output

3
-99993
3
12
100007
-199987
-99993
100019
200013
-399969
400031
-99939


首先要从给的表达式中找出规律,,,,每一列是单调的,,然后联想二分搜索的特性,,二分答案,枚举每一列,

再二分行标,求出该列能够满足的个数,从而找到矩阵不超过他的个数

注意 答案是long long 运算时用的变量也要是long long 不然数据会溢出

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long LL;
LL cal(LL x,LL y)
{
    return x*x + 100000*x + y*y - 100000*y + x*y;
}
LL judge(LL x);
LL n, m;


int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%I64d %I64d", &n, &m);
        LL l=-10000000000000LL,r=10000000000000LL, mid, ans;
        while(l<=r)
        {
            mid=(l+r)/2;
            if(judge(mid))
            {
                r=mid-1;
                ans=mid;
            }
            else
            {
                l=mid+1;
            }
        }
        printf("%I64d\n",ans);
    }
    return 0;
}


LL judge(LL x)
{
    LL cnt=0;
    for(int i=1;i<=n;i++)
    {
        LL l=1, r=n, mid, ans=0;
        while(l<=r)
        {
            mid=(l+r)/2;
            LL h=cal(mid,i);
            if(h>x)
            {
                r=mid-1;
            }
            else
            {
                l=mid+1;
                ans=mid;
            }
        }
        cnt+=ans;
    }
    if(cnt>=m)
    {
        return 1;
    }
    return 0;
}

Time Limit: 6000MS Memory Limit: 65536KB 64bit IO Format: %lld & %llu

 Status

Description

Given a N × N matrix A, whose element in the i-th row and j-th column Aij is an number that equals i2 + 100000 × i + j2 - 100000 × j + i × j, you are to find the M-th smallest element in the matrix.

Input

The first line of input is the number of test case.
For each test case there is only one line contains two integers, N(1 ≤ N ≤ 50,000) and M(1 ≤ M ≤ N × N). There is a blank line before each test case.

Output

For each test case output the answer on a single line.

Sample Input

12

1 1

2 1

2 2

2 3

2 4

3 1

3 2

3 8

3 9

5 1

5 25

5 10

Sample Output

3
-99993
3
12
100007
-199987
-99993
100019
200013
-399969
400031
-99939
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值