hihocoder 1385 A Simple Job(STL)

#1385 : A Simple Job

时间限制: 1000ms
单点时限: 1000ms
内存限制: 256MB

描述

Institute of Computational Linguistics (ICL), Peking University is an interdisciplinary institute of science and liberal arts, it focuses primarily on the fundamental researches and applications of language information processing. The research of ICL covers a wide range of areas, including Chinese syntax, language parsing, computational lexicography, semantic dictionaries, computational semantics and application systems.

Professor X is working for ICL. His little daughter Jane is 9 years old and has learned something about programming. She is always very interested in her daddy's research. During this summer vacation, she took a free programming and algorithm course for kids provided by the School of EECS, Peking University. When the course was finished, she said to Professor X: "Daddy, I just learned a lot of fancy algorithms. Now I can help you! Please give me something to research on!" Professor X laughed and said:"Ok, let's start from a simple job. I will give you a lot of text, you should tell me which phrase is most frequently used in the text."

Please help Jane to write a program to do the job.

输入

There are no more than 20 test cases.

In each case, there are one or more lines of text ended by a line of "####". The text includes words, spaces, ','s and '.'s. A word consists of only lowercase letters. Two adjacent words make a "phrase". Two words which there are just one or more spaces between them are considered adjacent. No word is split across two lines and two words which belong to different lines can't form a phrase. Two phrases which the only difference between them is the number of spaces, are considered the same.

Please note that the maximum length of a line is 500 characters, and there are at most 50 lines in a test case. It's guaranteed that there are at least 1 phrase in each test case.

输出

For each test case, print the most frequently used phrase and the number of times it appears, separated by a ':' . If there are more than one choice, print the one which has the smallest dictionary order. Please note that if there are more than one spaces between the two words of a phrase, just keep one space.

样例输入
above,all ,above all good at good at good
at good at above all me this is
####
world hello ok
####
样例输出
at good:3

hello ok:1

输入流的使用,字符串中地址的技巧,,,,受教了,,,算法的学习固然重要,但是工具的学习才是基础。

思维的差距很大,同样想到了一个方法点,因为麻烦思路转瞬即逝,选择了回避,然而别人却正视难点想出了方法,,,要敢于尝试敢于想

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <string>
#include <sstream>
#include <map>
#include <vector>
using namespace std;
map<string,int>p1;
const int N = 10000;
string s3, a, b, c;
char str[N];
int dis[N];
struct node
{
    int num;
    string name;
}p[N];


int main()
{
    p1.clear();
    int res=0;
    while(gets(str))
    {
        if(strcmp(str,"####")==0)
        {
            cout<<s3<<":"<<res<<endl;
            p1.clear();
            res=0;
            continue;
        }
        int cnt=1;
        dis[0]=0;
        for(int i=0;str[i];i++)
        {
            if(str[i]==','||str[i]=='.')
            {
                dis[cnt++]=i+1;
                str[i]=0;
            }
        }
        for(int i=0;i<cnt;i++)
        {
            stringstream ss(str+dis[i]);
            ss>>a;
            while(ss>>b)
            {
                c=a+' '+b;
                if(!p1.count(c))
                {
                    p1[c]=1;
                }
                else
                {
                    p1[c]++;
                }
                if(res==0||(p1[c]>res)||((p1[c]==res)&&c<s3))
                {
                    res=p1[c];
                    s3=c;
                }
                a=b;
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值