HDU 3033 I love sneakers!(分组背包->每组至少取一个)

I love sneakers!
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

After months of hard working, Iserlohn finally wins awesome amount of scholarship. As a great zealot of sneakers, he decides to spend all his money on them in a sneaker store. 

There are several brands of sneakers that Iserlohn wants to collect, such as Air Jordan and Nike Pro. And each brand has released various products. For the reason that Iserlohn is definitely a sneaker-mania, he desires to buy at least one product for each brand. 
Although the fixed price of each product has been labeled, Iserlohn sets values for each of them based on his own tendency. With handsome but limited money, he wants to maximize the total value of the shoes he is going to buy. Obviously, as a collector, he won’t buy the same product twice. 
Now, Iserlohn needs you to help him find the best solution of his problem, which means to maximize the total value of the products he can buy.

Input

Input contains multiple test cases. Each test case begins with three integers 1<=N<=100 representing the total number of products, 1 <= M<= 10000 the money Iserlohn gets, and 1<=K<=10 representing the sneaker brands. The following N lines each represents a product with three positive integers 1<=a<=k, b and c, 0<=b,c<100000, meaning the brand’s number it belongs, the labeled price, and the value of this product. Process to End Of File.

Output

For each test case, print an integer which is the maximum total value of the sneakers that Iserlohn purchases. Print "Impossible" if Iserlohn's demands can’t be satisfied.

Sample Input

5 10000 3
1 4 6
2 5 7
3 4 99
1 55 77
2 44 66

Sample Output

255


多重背包的变种

固化的思维难以适应多变的题目

这里递推公式不难想 dp[i][j]=max(dp[i][j],dp[i-1][j-c[i][k]]+v[i][k],dp[i][j-c[i][k]]+v[i][k])

dp[i][j]表示前 i 组每组至少选一个,花费 j 获得的最大价值

现在问题是怎么保证每组至少选一个,每个至多选一次。详见代码注释部分。



背包的思维度太大,技巧太多,可研究的领域太广。。。



#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int N = 100010;
const int inf = 999999999;
int dp[20][N], num[N];
struct node
{
    int v, w;
}p[20][N];


int main()
{
    int n, m, k, a, b, c;
    while(scanf("%d %d %d", &n, &m, &k)!=EOF)
    {
        memset(num,0,sizeof(num));
        memset(dp,-1,sizeof(dp));
        for(int i=0;i<n;i++)
        {
            scanf("%d %d %d", &a, &b, &c);
            p[a][num[a]].v=c, p[a][num[a]].w=b;
            num[a]++;
        }
        dp[0][0]=0;
        for(int i=1;i<=k;i++)
        {
            for(int j=0;j<num[i];j++)
            {
                int v=p[i][j].v,w=p[i][j].w;
                for(int x=m;x>=w;x--)
                {
                    if(dp[i][x-w]!=-1)
                        dp[i][x]=max(dp[i][x-w]+v,dp[i][x]);
                    if(dp[i-1][x-w]!=-1)
                        dp[i][x]=max(dp[i-1][x-w]+v,dp[i][x]);
                }
            }
        }
        int ans=-1;
        for(int i=0;i<=m;i++)
        {
            ans=max(ans,dp[k][i]);
        }
        if(ans!=-1)
            printf("%d\n",ans);
        else
            printf("Impossible\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值